Forum Discussion

stores80's avatar
Occasional Contributor
6 years ago

Getting null pointer exception when calling Run Test Case at load

I am receiving a null pointer exception when calling 'Run Test Case' at load. When calling the test case I’ve set the option to ‘Run primary TestCase (wait for running to finish, Thread-Safe) in the options. Each time a thread needs the next unique index to use, this test case will be locked so that the variables can’t be accessed/overwritten by another thread. Every now and again though I get a null pointer exception, mainly when the thread count goes up to around 5.


I have tried to make the call using the 'Run Test Case' option, and also via a Groovy script, but I always seem to see several of these errors during a performance run, especially when I have more than 3 threads running. The abreviated error:



at Source)


I am totally confused, as far as I am aware, I have coded this as per it's intended use when running multiple threads.


I am running version 5.0.0 of SoapUI Open Source.


Could this be a bug which has subsequently been fixed in a later version?


Many thanks

1 Reply

  • KonstantinosLps's avatar
    Occasional Contributor


    have you tried this with a newer version? You can install multiple Soapui versions in your PC and use it seperately.