Forum Discussion

gaffurs's avatar
7 years ago

Getting java.lang.OutOfMemoryError: Java heap space error if i run test with Launch Test runner

Hello Everyone,


Currently i am facing the Out of Memory error while running the test using the Launch TestRunner and is working perfectly if i run it through the UI. Below is my project structure. Using Open source SOAP UI 5.4.0.



   test suite1

     test case

         request1 ( using data driven with 40 sets of data)

     test case 2

          request2 ( using data driven with 40 sets of data)




like shown in above structure i have 1 test suite containing 20 test cases in it and a request in each test case. i am doing a data driven( using customized groovy script) for all of the requests in each test cases. Each request is executed with around 40 sets of test data.  Execution works well when i use normal UI run, if i use Launch Test runner or through command prompt i am getting the out of memory error.


I have tried with improving SOAP UI memory usage ( tricks but still i am getting the same error. Not even one test suite executed completely.


My system memory is 8GB and i allocated half in soap ui file in bin folder. CPU utilization is also going to 100% once i start the execution.


Is there any solution to make it work apart form increasing the system memory and checking whether it is working in that?


attaching the error screenshot.




Thanks for the help.