Forum Discussion

khurshidshaik's avatar
New Contributor
10 years ago

Failed to open workspace error

I am not able to access Soap UI today, when I tried to open it, I see this "Failed to open workspace: [ org.apache.xmlbeans.XmlException: C:\xxx\xxx\default-soapui-workspace.xml:1:1:error: Illegal XML character: 0x0 Illegal XML character: 0x0....


create new one instead?

 I said Yes & nothing happens. I tried uninstalling & installing back, also tried restarting my computer a couple of times & nothing worked. I am not using the pro version. Please help.

SoapUI Error.png

5 Replies

  • Mercedes's avatar
    Occasional Visitor

    I deleted the file "default-soapui-workspace.xml" and it worked correctly. The file was empty and corrupt. Doing this works well, but you can not recover projects. 

  • Open "default-soapui-workspace.xml", select All & delete All and paste the following xml & it worked. 


    <?xml version="1.0" encoding="UTF-8"?>
    <con:soapui-workspace name="Projects" soapui-version="5.0.0" xmlns:con="">
    <con:project name="mt_regression">C:/Users/ykns001/Documents/SOAP UI projects backedup_302015/mt_regression.xml</con:project>



  • tcsonka's avatar
    New Contributor


    I just got the same error.
    I moved the default-soapui-workspace.xml to another folder and then started SOAP UI Pro 5.1.2.
    It worked, I was able to start SOAP UI, but it can't open my project xml, it seems like that is corrupted as well. Can I recover my work somehow? And do you know how can this happen?


    • nmrao's avatar
      Champion Level 3
      I believe, you should be able to import existing projects into the new workspace. Because, new workspace might be empty.
      • tcsonka's avatar
        New Contributor

        I was able to import the project, but there is a red X on the project in SOAP UI and when I open the project xml in notepad++, it is full of NUL characters. I had a backup, so I lost only a few hours of work, but it would be good to know what caused the issue.