Forum Discussion

shlshl211's avatar
New Contributor
9 years ago

ERROR [errorlog] nu.xom.MalformedURIException: Double slash (//) in path

I run my testsuite in soapui-5.2.1 successfully. But when I use testrunnner.bat to test, show the following error. Actually my testsuite can ran successfully without any error. I do not know how to solve the problem.



2016-05-18 13:28:11,658 ERROR [errorlog] nu.xom.MalformedURIException: Double slash (//) in path
nu.xom.MalformedURIException: Double slash (//) in path
at nu.xom.Verifier.throwMalformedURIException(
at nu.xom.Verifier.checkPath(
at nu.xom.Verifier.checkAbsoluteURIReference(
at nu.xom.Element._setNamespaceURI(
at nu.xom.Element.setNamespaceURI(
at com.eviware.soapui.impl.wsdl.submit.transports.http.BaseHttpResponse.getContentAsXml(
at com.eviware.soapui.impl.wsdl.teststeps.RestTestRequestStep.propertyChange(
at java.beans.PropertyChangeSupport.firePropertyChange(
at java.beans.PropertyChangeSupport.firePropertyChange(

6 Replies

  • nmrao's avatar
    Champion Level 3
    Are you using it for rest? Can you see if the endpoint contains // at the end, check it in the raw request.
    • shlshl211's avatar
      New Contributor

      Thank you for reply. I have see the raw request. The request has no double slash. But error really exist.


      INFO [SoapUITestCaseRunner] running step [GetLabels - Job06]
      13:31:54,744 DEBUG [HttpClientSupport$SoapUIHttpClient] Attempt 1 to execute request
      13:31:54,745 DEBUG [SoapUIMultiThreadedHttpConnectionManager$SoapUIDefaultClientConnection] Sending request: GET /v1/job-servic e/jobs/19/labels HTTP/1.1
      13:31:54,767 DEBUG [SoapUIMultiThreadedHttpConnectionManager$SoapUIDefaultClientConnection] Receiving response: HTTP/1.1 200 OK
      13:31:54,767 DEBUG [HttpClientSupport$SoapUIHttpClient] Connection can be kept alive for 180000 MILLISECONDS
      13:31:54,769 ERROR [SoapUI] An error occurred [Double slash (//) in path], see error log for details

      • chaitanyahegde's avatar
        Occasional Visitor

        Hi shlshl211,


        Were you able to fix this issue ?

        Could you please provide your suggestions if you have fixed it as I am also facing the same issue.