Forum Discussion

wsealock's avatar
New Contributor
14 years ago

TestComplete Automation Bridge won't register

Hi All,

I'm using the evaluation version of TestComplete 8.10 (also with ALMComplete evaluation - the Saas version).  I'm trying to get the automation bridge (to ALMComplete) setup in TestComplete, but it's just not working.  Something is wrong, I believe, on the TestComplete side, but I can't narrow down where the problem is. 

In the registration screen I enter the web service address, email and password.  After clicking 'Load Projects' I am able to select my ALMComplete project.  I then enter the correct PJS directory, the correct Logfile file folder (both folders exist and are correct - I've checked this 10 times), the PC hostname, select to Run with TestComplete 8.  I also disable the QTP Bridge.  When I click OK I get the error "The system cannot find the file specified".  The end result, of course, is that if I run tests in TestComplete, the results won't show up in ALMComplete.

I'm not sure why I'm seeing this error as the only file paths selected are valid, nor do I know what file it's trying to find.  Has anyone seen this before?

6 Replies

  • Hi Warren -

    We have seen that particular error on a couple of desktops.  Our team just released a correction to the automation bridge that will fix the problem.

    You'll need to uninstall the current automation bridge, then grab the latest & greatest from our downloads page:

    Sorry about that! Let us know how it goes!
  • wsealock's avatar
    New Contributor
    Hi Barbara,

    I downloaded the new automation bridge and now, from TestComplete, I am able to register the bridge to my ALMComplete project. 

    At least, it says it's registered, but I'm not so sure. In TestComplete, I've created a Project Suite with one Test Project, and this Test Project has a keyword test created.  For this project I've aded a test item for this keyword test.  When I run this test from the project it works fine in TestComplete, but nothing ever shows up in ALMComplete (under the Automation Run item) at all.  Note, I'm running the test from the project, not the keyword test view.  I'm sure that the update to ALMComplete isn't instantaneous (because I'm using the Saas version), but I've run this test a number of times, and nothing at all is showing up in ALMComplete.

    Also, interestingly, on this same PC, if I'm logged into ALMComplete and go to the Automation Scheduler, if I try to add a new item, a pop-up appears indicating where to download the automation bridge - if I clear that pop-up the view goes back to the Automation Schedule screen.  Thus I also unable to see any of my automated tests from the Automation Scheduler either, even though the automation bridge is installed (and registered) on this PC.

    Any help would be appreciated.
  • Hi Warren,

    In TestComplete, make sure you are running the tests from the "organize tests" area. If you run them from the build area, it won't go to SoftwarePlanner - we don't want to send tons of results when you are still building and checking out your scripts or keyword tests.

    About the automation scheduler: the pop up appears because you need to install the bridge to use both the TestComplete to SoftwarePlanner bridge and the Automation Scheduler. That's where you set up the schedules: you'll see the results over in the Automation Runs area. If I'm not understanding the issue, I might need some screen shots, and the best way to track it would be to go ahead and submit a support ticket for us.


  • wsealock's avatar
    New Contributor
    Hi Barbara,

    I am running the tests from the Project tab (i.e., if I double click my project name a new tab with that project name appears).  This tab has a "Test Items" tab, and this where I'm running the tests from - I'm not running the tests from the keyword/script areas.

    This is all happening on one PC.  This PC has TestComplete 8.10, and the Software Planner bridge installed.  I'm also contacting ALMComplete from this same PC - so I'm not expecting the pop-up indicating the bridge isn't installed.  I.e., TestComplete seems to think the Software Planner bridge is installed, but ALMComplete doesn't. 

    I've put a ticket in with support for this.

  • Im Experiencing exactly the same issue. Test Complete can send defects and I can view them in QAComplete.

    But in QAComplete I cant see nothing for the tests I executed in Test Complete.