Forum Discussion

Kostja's avatar
8 years ago

QAComplete doesn't launch test on remote computer (physical machine)

Hi everybody,


i'm experiencing a strange behaviour. We changed from a VM to a physical machine to launch our tests with QAComplete. On the VM we used to use an user account with a password and the launch worked fine, but had to change to the physical machine, because the tests run far better and stable on it.


Now to the issue on the physical machine:


If we use a password, the tests are not launched even though everything is configured correctly in the TestAgent (already tried with enabling and disabling the checkbox for using an active session). We plugged a monitor the physical machine to see what happens. When the physical machine gets the impulse from QAComplete it changes to the logon and then happens nothing. But if there is an active remote window open it does launch the tests. In short: with password -> no active remote window -> no tests launch on the physical machine | without password -> no active remote window -> tests are launched on the physical machine


Otherwise if we deactivate the password the tests are launched flawlessly, but it is impossible to connect and watch the test run (which was possible on the VM), because we'll always be kicked instantly.


Can anybody tell me what the source of this behaviour is?


PS: We use the On-premise edition of QAComplete and the PM runs with Windows 10. 


PPS: The VM is no option anymore, since the error rate was simply to high (although it had 16 GB of RAM) .


Thanks in advance.

1 Reply

  • Nastya_Khovrina's avatar
    SmartBear Alumni (Retired)

    Hi Kostja,


    The following group policies should be disabled on the remote computer:
    * Always prompt client for password upon connection
    * Prompt for credentials on the client computer (on Windows Vista and later)
    If the remote computer belongs to a domain, these policies must also be disabled on the domain controller.

    And the following group policy is enabled on it and the security layer is set to Negotiate.
    * Require use of specific security layer for remote (RDP) connections​
    For instructions, see Configure Group Policies [].


    Customer Care Team