Forum Discussion

mspasova's avatar
mspasova
New Member
2 years ago

Password invalid when I try to attach code to existing review

I see:

ERROR: Could not configure SCM system:
Unexpected output on stderr starting with:
Password invalid.

when I try to attach code to existing review or create a new review.
Yesterday I didn't have any issues with it. I haven't updated my password.
In the collaborator log files the error is:

!ENTRY com.smartbear.collaborator.ui 4 0 2022-02-25 11:29:51.155
!MESSAGE No SCM Configuration could be determined
!STACK 0
com.smartbear.scm.ScmConfigurationException: Unexpected output on stderr starting with:
Password invalid.
at com.smartbear.scm.impl.newp4.P4System.getClientConfiguration(P4System.java:135)
at com.smartbear.scm.impl.newp4.P4System.getClientConfiguration(P4System.java:85)
at com.smartbear.scm.impl.perforce.PerforceSystem.getClientConfiguration(PerforceSystem.java:119)
at com.smartbear.scm.ScmUtils.requireScm(ScmUtils.java:597)
at com.smartbear.collaborator.ui.standalone.wizards.StandaloneScmConfigAddToReviewWizard$1.run(StandaloneScmConfigAddToReviewWizard.java:82)
at com.smartbear.collaborator.ui.wizards.ProgressWizardDialog$AsyncWorkerThread.run(ProgressWizardDialog.java:231)
Caused by: com.smartbear.cmdline.ScmCommunicationException: Unexpected output on stderr starting with:
Password invalid.
at com.smartbear.scm.cmd.impl.ScmCmds.throwIfNotEmpty(ScmCmds.java:52)
at com.smartbear.scm.cmd.impl.ScmCmds.throwIfNotEmpty(ScmCmds.java:26)
at com.smartbear.scm.impl.newp4.cli.P4LoginCmd.handleStdErr(P4LoginCmd.java:41)
at com.smartbear.scm.cmd.impl.ScmTextCmdAdapter.handleStdErr(ScmTextCmdAdapter.java:42)
at com.smartbear.scm.cmd.impl.CommandRunner$3.run(CommandRunner.java:172)
at com.smartbear.scm.cmd.impl.CommandRunner$3.run(CommandRunner.java:169)
at com.smartbear.scm.cmd.impl.CommandRunner$StreamHandler.call(CommandRunner.java:225)
at com.smartbear.scm.cmd.impl.CommandRunner$StreamHandler.call(CommandRunner.java:215)
at java.util.concurrent.FutureTask.run(Unknown Source)
at java.util.concurrent.ThreadPoolExecutor.runWorker(Unknown Source)
at java.util.concurrent.ThreadPoolExecutor$Worker.run(Unknown Source)
at java.lang.Thread.run(Unknown Source)

I tried what was suggested here https://community.smartbear.com/t5/Collaborator-Questions/Unable-to-configure-SCM/td-p/44445 but it didn't help me.

1 Reply

  • Judging from what I see in the errors, I am making an assumption that you are using PerForce as your SCM. I'd recommend checking the PerForce configuration in your Client GUI. Ensure that the server information is still correct and that the password for connection to the SCM is still valid.

    You can also validate your connection to the Collaborator server itself. Go to File > Preferences and Test Connection to the Collaborator server.