Forum Discussion

MichaelMcFarlan's avatar
13 years ago

Blue screen of death using Allocation profiler

I'm not having much luck using some of AQtime's more in depth profilers. I tried using the Reference Count Profiler and the program got a "<name>.exe has stopped working" error. I tried use the Allocation profiler and I consistently get the blue screen of death although not always at the same place/time.

I remember using these same profilers a year or so ago without this issue. I'm not really expecting much in terms of resolving this but I figured I'd say something.

AQtime 7.30.537.64, Windows 7 Premium 64bit, plenty of memory and cpu power for everyone... The software I'm testing is written in Delphi, I'll be experimenting with some other Delphi software we have and see if I get more problems.

4 Replies

  • Although I'm still only getting the blue screen on our main software application, another smaller/lighter application is freezing up with the windows ".. has stopped working message" using the Allocation profiler, some of the time. It's a shame too, the first time it worked and I actually managed to see some improvements I could make to my code (just freeing some objects up) and now I want to the see if the improvements solved all the leftover objects.. but now it freezes every time right when I close the program.
  • More blue pixels today.. this time trying out the Performance Profiler. The message at the top said "Modification of system code or a critical data structure was detected." Googled it and I the best results I saw were to check my memory.. but this problem is only happening when I use AQtime so I'm not sure if I really should. Might run some memory tests tonight just for the sake of it.

    Problem signature:

      Problem Event Name:    BlueScreen

      OS Version:    6.1.7601.

      Locale ID:    1033

    Additional information about the problem:

      BCCode:    109

      BCP1:    A3A039D89E62B9A5

      BCP2:    B3B7465EF0DF88FB

      BCP3:    FFFFF80002FCE840

      BCP4:    0000000000000001

      OS Version:    6_1_7601

      Service Pack:    1_0

      Product:    256_1
  • Seems like the problem might be running the Allocation profiler while I have a VirtualBox machine running... interesting.. won't be an issue anymore though because the blue screen seems to have corrupted my virtual machine beyond repair. Nothing lost fortunately.