Ask a Question

The operation cannot be performed, because the desktop is invisible.

SOLVED
tc_2018
Contributor

The operation cannot be performed, because the desktop is invisible.

Hi,

 

In the past, my tests were running fine while remote desktop is minimized.

 

After getting a new computer (this is the one that connects to a remote desktop system), I added a DWORD value named RemoteDesktop_SuppressWhenMinimized and set it to 2 (hexadecimal or decimal) to HKEY_LOCAL_MACHINE\Software\Microsoft\Terminal Server Client.

 

I also updated TestComplete to version 14.50.976.7 on the remote system.

 

Now, I got the error message saying that :"The operation cannot be performed, because the desktop is invisible." when minimizing the remote desktop.

Does anyone seeing the same issue with the latest TestComplete version? Can anyone shed some light? Thanks.

3 REPLIES 3
Marsha_R
Community Hero

That's a good question for Support.  Here's their link:

https://support.smartbear.com/message/?prod=TestComplete


Marsha_R
[Community Hero]
____
[Community Heroes] are not employed by SmartBear Software but
are just volunteers who have some experience with the tools by SmartBear Software
and a desire to help others. Posts made by [Community Heroes]
may differ from the official policies of SmartBear Software and should be treated
as the own private opinion of their authors and under no circumstances as an
official answer from SmartBear Software.
The [Community Hero] signature is used with permission by SmartBear Software.
https://community.smartbear.com/t5/custom/page/page-id/hall-of-fame
Wamboo
Community Hero

@Marsha_R, Sean ONeil at SmartBear helped me to solve this issue. There was an extra whitespace at the end in the name of my registry key.

cancel
Showing results for 
Search instead for 
Did you mean: