Ask a Question

The Browser("chrome") does not contain Page("*").

SOLVED
jcatayong
Contributor

The Browser("chrome") does not contain Page("*").

The Browser("chrome") does not contain Page("*"). error when running the test using testexecute. The chrome browser open but unable to navigate to page. Waiting process ("*") appear. My Testexecute version is 12.50 and my chrome version is 67.
thanks in advance.

1 ACCEPTED SOLUTION

Accepted Solutions
AlexKaras
Community Hero

Re: The Browser("chrome") does not contain Page("*").

Hi Jeff,

 

Using Chrome, try to navigate to the https://chrome.google.com/webstore/detail/smartbear-test-extension/gmhjclgpamdccpomoomknemhmmialaae address and install extension from there.

 

 

The above address was taken from the https://community.smartbear.com/t5/TestComplete-Functional-Web/Chrome-Extension-not-working-on-Windo... thread.

 

Does it help?

 

P.S. OK, I see that you've already followed the advice provided in the referenced thread and it worked for you πŸ™‚

Regards,
  /Alex [Community Hero]
____
[Community Heroes] are not employed by SmartBear Software but
are just volunteers who have some experience with the tools by SmartBear Software
and a desire to help others. Posts made by [Community Heroes]
may differ from the official policies of SmartBear Software and should be treated
as the own private opinion of their authors and under no circumstances as an
official answer from SmartBear Software.
The [Community Hero] signature is used with permission by SmartBear Software.
https://community.smartbear.com/t5/custom/page/page-id/hall-of-fame
================================

View solution in original post

6 REPLIES 6
AlexKaras
Community Hero

Re: The Browser("chrome") does not contain Page("*").

Hi,

 

Chrome 67 should be supported for TC 12.5 as per https://support.smartbear.com/downloads/testcomplete/chrome-patches/.
So start Chrome and check if TestComplete extension is installed and enabled (https://support.smartbear.com/testcomplete/docs/app-testing/web/general/preparing-browsers/chrome.ht... and https://support.smartbear.com/testcomplete/docs/app-testing/web/general/preparing-browsers/chrome-ex...)

Regards,
  /Alex [Community Hero]
____
[Community Heroes] are not employed by SmartBear Software but
are just volunteers who have some experience with the tools by SmartBear Software
and a desire to help others. Posts made by [Community Heroes]
may differ from the official policies of SmartBear Software and should be treated
as the own private opinion of their authors and under no circumstances as an
official answer from SmartBear Software.
The [Community Hero] signature is used with permission by SmartBear Software.
https://community.smartbear.com/t5/custom/page/page-id/hall-of-fame
================================
jcatayong
Contributor

Re: The Browser("chrome") does not contain Page("*").

Hi,

 

My TestComplete works fine. It's TestExecute that getting issue with Chrome. 
I'm running my test on a remote computer where TestExecute is installed. Do I need to install TestComplete extension on that machine too?

Thanks,

Jeff

AlexKaras
Community Hero

Re: The Browser("chrome") does not contain Page("*").

> Do I need to install TestComplete extension on that machine too?

Yes, definitely. TestComplete Chrome extension must be installed in Chrome on all machines and for all users that are used to execute tests, regardless of whether tests are executed using TestComplete or TestExecute.

Regards,
  /Alex [Community Hero]
____
[Community Heroes] are not employed by SmartBear Software but
are just volunteers who have some experience with the tools by SmartBear Software
and a desire to help others. Posts made by [Community Heroes]
may differ from the official policies of SmartBear Software and should be treated
as the own private opinion of their authors and under no circumstances as an
official answer from SmartBear Software.
The [Community Hero] signature is used with permission by SmartBear Software.
https://community.smartbear.com/t5/custom/page/page-id/hall-of-fame
================================
jcatayong
Contributor

Re: The Browser("chrome") does not contain Page("*").

Hi Alex, 

Can't find SmartBear extension on my remote computer where testExecute is installed. I tried this step from SmartBear documentation :

Reinstalling SmartBear Test Extension

If you remove SmartBear Test Extension from Chrome, it will be blacklisted and TestComplete will not be able to automatically reinstall or update it. In this case, to reinstall the extension:

  • From Chrome’s main menu, select Settings and switch to the Extensions page.

    -- or --

    Navigate to the chrome://extensions page.

  • In the <Program Files>\<Common Files>\SmartBear\tcCrExtension\<alphanumeric_ID> folder, locate the SmartBear Test Extension file - the tcCrExtension.crx file.

  • Drag the tcCrExtension.crx file to the Extensions page in Chrome.

  • Confirm the installation when prompted.

 

unfotunately dragging the file "tcCrExtension.crx " to Chrome extension page doesn't work. 

thanks,

Jeff

AlexKaras
Community Hero

Re: The Browser("chrome") does not contain Page("*").

Hi Jeff,

 

Using Chrome, try to navigate to the https://chrome.google.com/webstore/detail/smartbear-test-extension/gmhjclgpamdccpomoomknemhmmialaae address and install extension from there.

 

 

The above address was taken from the https://community.smartbear.com/t5/TestComplete-Functional-Web/Chrome-Extension-not-working-on-Windo... thread.

 

Does it help?

 

P.S. OK, I see that you've already followed the advice provided in the referenced thread and it worked for you πŸ™‚

Regards,
  /Alex [Community Hero]
____
[Community Heroes] are not employed by SmartBear Software but
are just volunteers who have some experience with the tools by SmartBear Software
and a desire to help others. Posts made by [Community Heroes]
may differ from the official policies of SmartBear Software and should be treated
as the own private opinion of their authors and under no circumstances as an
official answer from SmartBear Software.
The [Community Hero] signature is used with permission by SmartBear Software.
https://community.smartbear.com/t5/custom/page/page-id/hall-of-fame
================================

View solution in original post

jcatayong
Contributor

Re: The Browser("chrome") does not contain Page("*").

Hi,

 

Yes, this is the same solution I found from the community.

 

Thanks,

Jeff

cancel
Showing results forΒ 
Search instead forΒ 
Did you mean:Β