Ask a Question

Logging far too slow since using remote clients

SOLVED
Manfred_F
Regular Contributor

Logging far too slow since using remote clients

I started to deploy my test from my local Computer to virtual machines.

Locally, all worked fine. But on the virtual machine, nothing seemed to happen in TestExecute.

I installed TC there to see what was going on.

 

The Observation is that writing a single Log entry (Log.Message, Log.Event) takes e.g. 30s, 60 s or 90s. After having worked with the remote TC instance, my original local TC has got the same Problem.

When I suppress a log entry in Event handling using Logparams.Locked = true, no delay happens.

 

The Project Suite had been on a Network share before.

What I did is to Change the logging dir from the Network share to a local disk. I applied a UserVariable for it to cover variance on remote virtual machines.

 

I tried to remove the uservariable, remove Event handling, but nothing helped.

 

Logging from a keyword test works normally, without any delay.

4 REPLIES 4
Manfred_F
Regular Contributor

[removed to new thread]

Manfred_F
Regular Contributor

[removed to new thread]

Manfred_F
Regular Contributor

did some more Investigation using a Project Suite in shared mode (TC 11). The Project files are located on a Network share, the loggiong is done locally.

 

Here is my test program:

 

Sub Test3

Dim Ix

For Ix = 1 to 6

log.Message "Msg " & Ix

Next

End Sub

 

 

Running this on my local machine, I get the attached log - on local machine.

So, between log msg 1 and 2, there are some seconds delay time (why is this?), but from there on, everything runs fast.

 

Running on a virtual Client, it looks like  the attached log - on virtual Client.

Between each log item, there is a 30s delay, which makes this pretty unusable.

 

Again, I suspect that the latest Win7 update could Play a role here?

Does anybody use shared mode?

Can anybody reproduce?

Manfred_F
Regular Contributor

Got that beast.

 

The Project contains a Performance Counter on my local PC. I use it to track TC's Memory shedding.

So, when I use my Project elsewhere, TC tries to read my local pc's TC private Bytes, which it can't.

TC then waits for the timeout, which is at 31s, and then continues without any error Information.

This is done on every usage of the Log object, making Automation useless.

 

This is a Bug.

cancel
Showing results for 
Search instead for 
Did you mean: