Ask a Question

FireFox object recognition stopped working after an update to testcomplete


FireFox object recognition stopped working after an update to testcomplete

With FF 87 and TC 14.80 I ran into an issue where only tests ran on Firefox abruptly stopped working. It says Unable to find the following object when executing SetText. This is just for logging into the website. I can use object spy and find the username and password objects in Firefox and it matches my name mapping. So I am confused why it stopped recognizing the object. Anyways I might have to abandon testing in firefox for the time being if I cannot find a solution. I was hoping the updates to FF 88 and most recent TC would fix it and it did not. 


hi @jthompson1 - 


There was recently a patch for FF 88 have you tried installing this update?


See if this helps.

Thanks. Yes, I shut down TC, dragged those files over into bin folders and relaunched. Same outcome... is there anything more to it that I might be missing?

Similar issue i am noticing with Google Chrome though it does not have any patches recommended.

Hi @tulasiametek and @jthompson1 


Hope all is well. 


Can you share what the error(s) are? 


When you use the object spy is TestComplete recognizing any controls? 


Outside of that its difficult to tell 


Have you checked for any browser related settings that could be causing this? 


I have TC 14.8 and my tests appear to be fine on both browsers. 


Now sometimes with different monitors I may need to change the DPI settings especially if you are like me and have multiple monitors. It might be worth just cross checking this or disconnecting from your extended monitor and checking your main laptop monitor. 


I am not ruling out it being a bug and raising a support case but I would at least cross check the browser settings and configuration on your display. 


For Firefox specific settings see

For Chome:


For raising a case with support see:


Consider the above, give it a try and let me know how you get on





Hello Vincent,


All is well and hope the same with you.


Object Recognition is failing in Chrome for Confirmation Window.

Once the Confirmation Window is cancelled, Objects are recognized successfully.

The issue is not getting fixed on reverting to Build 14.74.437.7.

The objects have always recognized and have never seen this issue in any of the previous builds.


I Submitted Customer Case #00475564 and was immediately responded with a patch for both Test Complete and Test Execute which worked like a charm.


The issue is resolved now.


Many Thanks,


Hi @tulasiametek 


thats great, delighted you got the issue fixed. 


@jthompson1 have you opened a support case? 


There may also be fix for this





Showing results for 
Search instead for 
Did you mean: