Ask a Question

FireFox not working on a simple Search

SOLVED
MarkSchofer
Frequent Contributor

FireFox not working on a simple Search

This script works everywhere except in the FireFox Browser..........

 

Version: 14.90.432.7 x64 -Purposely on this version for now

 

def FindTPA():
# display log messages in bold green letters
attr = Log.CreateNewAttributes()
attr.FontColor = clGreen
attr.Bold = True

if Sys.WaitBrowser().Exists:
#Browsers.Item[btIExplorer].Navigate("http://qat3.q.pers.state.or.us/Clarety/SAMyClarety.do");
browser = Aliases.browser
# else:
# Log.Message("No browser is open")
# newEmplr().quit() #exit()

#page = browser.pageMyclaretyPage
page = browser.Page("*")

#page.tableTop.cell.formUnitform.linkMyClarety.Click()
PropArray = ["ObjectType","ObjectLabel"]
ValuesArray = ["Link","View/Manage Healthcare Deductions"];
page.FindChild(PropArray, ValuesArray, 10).click()
page.Wait()
myTPA = page.FindChild(PropArray, ValuesArray,10)
if (myTPA.exists):
Log.Message("Ready To Begin")

1 ACCEPTED SOLUTION

Accepted Solutions
Marsha_R
Community Hero

Re: FireFox not working on a simple Search

Looks like your TC version wants Firefox 89. You can try to revert your FF or see if Support can add a patch for that version. It's not always possible but it's worth a try.

https://support.smartbear.com/testcomplete/downloads/firefox-patches/

View solution in original post

4 REPLIES 4
Marsha_R
Community Hero

Re: FireFox not working on a simple Search

You might want to keep your license info private.   

 

What version of Firefox are you using? 

Which part of the script is failing?

Do you get an error message?

MarkSchofer
Frequent Contributor

Re: FireFox not working on a simple Search

Thanks for the reminder. This is an opening script to a longer program.  It is the code I have posted. Very simple search for a link.

I understand FF puts out a new version constantly. 

 

FireFox 92.0.1 #page = browser.pageMyclaretyPage
page = browser.Page("*")

Marsha_R
Community Hero

Re: FireFox not working on a simple Search

Looks like your TC version wants Firefox 89. You can try to revert your FF or see if Support can add a patch for that version. It's not always possible but it's worth a try.

https://support.smartbear.com/testcomplete/downloads/firefox-patches/

View solution in original post

MarkSchofer
Frequent Contributor

Re: FireFox not working on a simple Search

yeah thanks again.....I do not have the choice on the Server I am working yet this explains things and I have a root cause.

cancel
Showing results for 
Search instead for 
Did you mean: