Ask a Question

Soapui not starting on Ubuntu 15.04

SOLVED
sample
Contributor

Re: Soapui not starting on Ubuntu 15.04

Hi,

 

I have been trying 5.2.1 version only.

 

Thanks

rupert_anderson
Valued Contributor

Re: Soapui not starting on Ubuntu 15.04

 method Hi, 

 

Sorry that was a stupid question on my part, if I'd looked more closely at your stacktrace I would have seen the version 5.2.1 right there!

 

The strange thing is that the line numbers in the code aren't matching up, so I thought I'd check. That makeUserId method looks fairly innocent, but is definately catching the error you're seeing:

 

private static String makeUserId() {
        try {
            NetworkInterface e = NetworkInterface.getByInetAddress(InetAddress.getLocalHost());
            byte[] mac = e.getHardwareAddress();
            MessageDigest hasher = MessageDigest.getInstance("SHA-1");
            return createHexBinary(hasher.digest(mac));
        } catch (Exception var3) {
            log.warn("Error generating Analytics session ID - returning empty String", var3);
            return "";
        }
    }

Possibly e is null, hard to say without debuggin it in ubuntu.. like I say none of these lines are 140...

 

If I get a chance I'll download ubuntu and install it on a VM, other than that I think I'm not really able to help directly, sorry about that.

 

Thanks,

Rupert

 

 

Author of SoapUI Cookbook
rupert_anderson
Valued Contributor

Re: Soapui not starting on Ubuntu 15.04

Hi,

 

Was just thinking, since the error seems to be in the Google Analytics code (which isn't necessary), have you tried disabling it?

 

I noticed that you can do it in in the Preferences (which you cant see as it doesn't start up), but you can also change it in the soapui-settings.xml:

 

<con:setting id="UISettings@disable_analytics">false</con:setting>

 

change to 

 

<con:setting id="UISettings@disable_analytics">true</con:setting>

 

Hope this helps,

Rupert

Author of SoapUI Cookbook
rupert_anderson
Valued Contributor

Re: Soapui not starting on Ubuntu 15.04

Hi,

Anybody getting these Nullpointer exceptions in Analytics when running on Ubuntu, please can you try this host file work-around and let me know if it works:

 

http://rupertanderson.com/blog/soapui-google-analytics-null-pointer-exception-on-ubuntu/

 

Seemed to work for me when I tested this running SoapUI 5.2.1 (built & run from source code) on a clean install of Ubuntu 14.04.4, Java 1.7u79 and running on VirtualBox.

 

Thanks,

Rupert

Author of SoapUI Cookbook
dsantiagol
Occasional Visitor

Re: Soapui not starting on Ubuntu 15.04

SoapUi version 5.2.1

 

Error solved modifyng settings.xml, deleting:

 

<con:setting id="com.eviware.soapui.SoapUI@workspace">../../TestPBE-workspace.xml</con:setting>

 

Others errors in log, but soapui opens

cancel
Showing results for 
Search instead for 
Did you mean: