Ask a Question

java.lang.Exception: DataSource not set in step ... when running SoapUI Pro with Maven Plugin

SOLVED
Bruce_Katz
New Contributor

java.lang.Exception: DataSource not set in step ... when running SoapUI Pro with Maven Plugin

I've looked into the forums and have found previous instances of similar errors, but none with solutions that made sense to me.

I'm using Soap UI Pro (Ready API) 1.8.5 and when run from within Soap UI Pro, or from command line on my local system with with "testrunner" everything is fine.

 

However, when run from Maven plugin (5.1.2) either locally, or in our dev ops environment, we receive the error in the subject line for each instance in Soap UI project where a DataSource test step is executed with the option to "generate" test data. For reference, I have other DataSource test steps that read data from files, set values in a grid, and as a pick list, none of those fail. Only those which use the "Data Generate" option are failing in this manner.

I've attached my pom.xml file, my project.xml file, and the test results log. Please note I cleaned my project.xml file to remove any sensitive data, such as end point references.

 

Thanks in advance for you help.

1 ACCEPTED SOLUTION

Accepted Solutions
TanyaYatskovska
Community Manager

Re: java.lang.Exception: DataSource not set in step ... when running SoapUI Pro with Maven Plugin

 

Hi Bruce_Katz,

 

As far as I see you are using the plugin for SoapUI (v. 5.1.2). From my understanding, you should use the Maven plugin for you Ready! API version. You can download it here:

http://smartbearsoftware.com/repository/maven2/com/smartbear/ready-api-maven-plugin/

 

Does it work for you?

 

---------
Tanya Yatskovskaya
SmartBear Community and Education Manager

Did my reply answer your question? Give Kudos or Accept it as a Solution to help others. ⬇️⬇️⬇️

View solution in original post

1 REPLY 1
TanyaYatskovska
Community Manager

Re: java.lang.Exception: DataSource not set in step ... when running SoapUI Pro with Maven Plugin

 

Hi Bruce_Katz,

 

As far as I see you are using the plugin for SoapUI (v. 5.1.2). From my understanding, you should use the Maven plugin for you Ready! API version. You can download it here:

http://smartbearsoftware.com/repository/maven2/com/smartbear/ready-api-maven-plugin/

 

Does it work for you?

 

---------
Tanya Yatskovskaya
SmartBear Community and Education Manager

Did my reply answer your question? Give Kudos or Accept it as a Solution to help others. ⬇️⬇️⬇️

View solution in original post

cancel
Showing results for 
Search instead for 
Did you mean: