Ask a Question

NTLM authentication with soapui for sharepoint webservice

luckyme
Not applicable

NTLM authentication with soapui for sharepoint webservice

Hi
Trying to test an out of the box SharePoint web service, search.asmx using SoapUI .The search web service to test requires NTLM authentication, each time when I try initiating a SoapuUI session,it prompted for my credentials and upon entering them the session keeps loading with a waiting progress bar.

Please help in solving the issue.

Thanks
lucky
1 REPLY 1
bkesava
New Contributor

Hi you can overcome that situation by enabling anonymous access on your website.

After that you need to do the following so that you dont get the 401 unauthorized error..

soapUI doesn’t seem to work directly with NTLM authentication, but you can use a proxy such as Burp Suite to do the auth for you.

Download Burp Suite from http://www.portswigger.net/burp/downloadfree.html and install it with default settings
On Burp’s “Proxy : Intercept” tab, click the button to turn intercept off.
On Burp’s “Proxy : Options” tab, make sure it’s set to an unused port, the default is 8081
On Burp’s “Options” tab, tick “do www authentication” and add a setting for the server you wish to hit. Also tick “prompt for credentials on authentication failure”
Switch to Burp’s “Proxy : History” tab so you can see requests going through.
In SoapUI, choose File > Preferences, then select “Proxy Settings”. Enter Host “localhost” and port “8081″.
Use SoapUI as normal. It will send requests through Burp Proxy, which will do the NTLM authentication for you.
cancel
Showing results for 
Search instead for 
Did you mean: