Ask a Question

Failed to start ReadyAPI error on launch

New Contributor

Failed to start ReadyAPI error on launch


I cannot launch ReadyAPI on one of my PCs. It crash when I click the icon in Start menu, the interface doesn't appear at all, just launch startup window.

OS: Windows 10 Enterprise ver. 1909


Works fine on Windows Server 2016


Log file attached.


Tried to find something here but there is nothing for Windows 10 and all post are a bit outdated so I decided to start a new post instead.

SmartBear Alumni (Retired)

Hi @mar_szwi,


It's sad to hear this. Could you please try installing the latest ReadyAPI maintenance build? You can download it here:


Please uninstall the current product version, reboot the system and install the new version. Do you see an issue when starting ReadyAPI now?

Tanya Yatskovskaya
SmartBear Community and Education Manager

Hi @TanyaYatskovska !

Thanks for replying to me! I already did that, with both 64 and 32 versions. I also tried to return to version 2.8.2 which I had previously and it worked previously, but results are the same...

I didn't reconfigure my PC lately, just installed a new web browser, do you think it may be relevant?



It seems that the issue is with your ReadyAPI settings.


Please open your "C:\Users\<UserName>\soapui-settings.xml" file in any text editor and set the right values for _HttpSettings@max_connections_per_host_ and _HttpSettings@max_total_connections_. The default values _500_ and _2000_ should work fine. These values cannot be 0, negative or too big.


Best regards,

Alexander Sviridov

ReadyAPI developer

You nailed it @ASviridov! Thank you very much 🙂

@mar_szwi, you are welcome!

Showing results for 
Search instead for 
Did you mean: