Ask a Question

DataBase inserts while overriding region with -e commandline argument

SOLVED
shalu
Occasional Contributor

DataBase inserts while overriding region with -e commandline argument

Hi,

We have full fledge ready api tests in our projects where in we have regions defined(Dev1, Dev2..) and for every step we inserts data using jdbc insert /update steps , run api and delete data . 

 

So my question is when we run scripts from command line using -e statement where in it will override endpoints to be called , how will ready api determine region of data to be inserted . 

 

example below

C:\SmartBear\ReadyAPI-3.3.2\bin\testrunner.bat -sService -r -a -j -fC:\Path\MyService "-RTestSuite Report"  -ehttp://region-dev0-blah.net/demf-my-test <path>

 

In above example api calls are working fine as its going to region http://region-dev0-blah.net/demf-my-test but my database inserts are failing as region is not specified . In this example how can i say that use url as "-ehttp://region-dev0-blah.net/demf-my-test" but do inserts in "Dev" environment

 

please help i am completely stuck here

1 ACCEPTED SOLUTION

Accepted Solutions
nmrao
Community Hero

Re: DataBase inserts while overriding region with -e commandline argument

How are you setting the active environment?
Here is the documentation how you can pass the commandline option for the same
https://support.smartbear.com/readyapi/docs/testing/environments/index.html

Please try as per documentation and revert back.


Regards,
Rao.

View solution in original post

3 REPLIES 3
nmrao
Community Hero

Re: DataBase inserts while overriding region with -e commandline argument

How sre the database details specified in the connection? Using environment?
A screen shot would help.



Regards,
Rao.
shalu
Occasional Contributor

Re: DataBase inserts while overriding region with -e commandline argument

yes using environmnents

 

Different environments Dev1 , Dev2 etc has different connection configs for DB2 and SQL

nmrao
Community Hero

Re: DataBase inserts while overriding region with -e commandline argument

How are you setting the active environment?
Here is the documentation how you can pass the commandline option for the same
https://support.smartbear.com/readyapi/docs/testing/environments/index.html

Please try as per documentation and revert back.


Regards,
Rao.

View solution in original post

cancel
Showing results for 
Search instead for 
Did you mean: