Ask a Question

CodeCollab GUI Error

BooHyunJang
Occasional Contributor

CodeCollab GUI Error

java.lang.NoClassDefFoundError: javax/xml/ws/http/HTTPException
at com.smartbear.ccollab.GuiMain.getMainCommand(GuiMain.java:72)
at com.smartbear.ccollab.GuiMain.main(GuiMain.java:48)
at java.base/jdk.internal.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at java.base/jdk.internal.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:64)
at java.base/jdk.internal.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
at java.base/java.lang.reflect.Method.invoke(Method.java:564)
at com.exe4j.runtime.LauncherEngine.launch(LauncherEngine.java:81)
at com.exe4j.runtime.WinLauncher.main(WinLauncher.java:94)
at com.install4j.runtime.launcher.WinLauncher.main(WinLauncher.java:25)
Caused by: java.lang.ClassNotFoundException: javax.xml.ws.http.HTTPException
at java.base/jdk.internal.loader.BuiltinClassLoader.loadClass(BuiltinClassLoader.java:606)
at java.base/jdk.internal.loader.ClassLoaders$AppClassLoader.loadClass(ClassLoaders.java:168)
at java.base/java.lang.ClassLoader.loadClass(ClassLoader.java:522)
... 9 more

 

MY DeskTOP OS : Win10

MY JAVA version : 1.8

 

In what cases do you get an error like the one above?

Tell me the solution.
please

1 REPLY 1
OlegB
SmartBear Alumni (Retired)

Hello @BooHyunJang,

 

This error may indicate corrupted instances of both Collaborator client or Java. It also can be caused by an unsupported Java vendor. Try to follow the steps below:

1. Uninstall the Collaborator client.

2. Launch the command prompt as administrator.

3. Navigate to the location of the Collaborator client installer and run it from the command prompt as below:

the_name_of_the_executable_file -manual

 

When the client installer is executed with the -manual option, it will ask you to provide the path to the Java location. If you see any exceptions, post them here. 

4. Check if the issue exists after re-installing the client. 

 

If the issue still occurs, try to uninstall Java completely, install Oracle Java 1.8, and follow the steps above one more time. 

Regards,
Oleg Beriashvili
Technical Support Engineer
cancel
Showing results for 
Search instead for 
Did you mean: