cancel
Showing results for 
Search instead for 
Did you mean: 

qsh error when creating test cycle with API

SOLVED
apuna12
Occasional Contributor

qsh error when creating test cycle with API

Hello all,

 

I am trying to create a testing cycle through an API   (currently Postman).

 

This is what I am doing

 

apuna12_0-1613387980222.png

apuna12_1-1613388002371.png

 

I am not using Authorization tab at all.

 

As a JWT generator I use this code in JAVA

 

apuna12_2-1613388071792.png

I tried both "GET" and "POST" methods.

 

 

An I still get the gsh error like seen in the first Image.

 

I am using the following site to get the idea how should I send an API

https://zfjcloud.docs.apiary.io/#reference/cycle/creates-new-cycle/creates-new-cycle?console=1

 

BTW: I am pretty sure that project ID and version is correct

 

Am I doing something wrong?

 

Can you please help me with this?

 

Thanks a lot 

Tags (5)
1 ACCEPTED SOLUTION

Accepted Solutions
apuna12
Occasional Contributor

Re: qsh error when creating test cycle with API

Hello Jagadeesh,

 

I did everything what was on the page you posted, but it did not help.

I created a ticket for that.

 

Thanks a lot 🙂

 

Have a nice day

View solution in original post

7 REPLIES 7

Re: qsh error when creating test cycle with API

 

Hi,

 

From screenshot i can see that  zephyrBaseUrl is wrong, please try with below url. 

String zephyrBaseUrl = "https://prod-api.zephyr4jiracloud.com/connect";

 

Thanks

Jagadeesh

apuna12
Occasional Contributor

Re: qsh error when creating test cycle with API

Hello Jagadeesh,

 

I tried it like you said, but didnt work.. I tried even GET method, I tried to delete the additional "/connect" still does not work. I am getting still the same error.

 

Currently it looks like this

 

apuna12_0-1613390815317.png

 

apuna12
Occasional Contributor

Re: qsh error when creating test cycle with API

Hello Jagadeesh,

 

I tried it like you said, but didnt work.. I tried even GET method, I tried to delete the additional "/connect" still does not work. I am getting still the same error.

 

Currently it looks like this

 

apuna12_0-1613391246475.png

 

Re: qsh error when creating test cycle with API

 

Hi ,

 

We have to pass the url as below,  also /connect is required - 

String zephyrBaseUrl = "https://prod-api.zephyr4jiracloud.com/connect";

Please follow our documentation, we have given step by step instructions on how to generate and use the api in post man - https://support.smartbear.com/zephyr-for-jira-cloud/docs/api/jwt-token.html

Note that you have to generate separate JWT for seperate endpoints, for eg: For GET method and POST method you have to generate different JWT tokens

If you are still facing issues, please create  Support ticket our team will help you

 

Thanks

Jagadeesh

apuna12
Occasional Contributor

Re: qsh error when creating test cycle with API

Hello Jagadeesh,

 

I did everything what was on the page you posted, but it did not help.

I created a ticket for that.

 

Thanks a lot 🙂

 

Have a nice day

View solution in original post

BibekBehera
Staff

Re: qsh error when creating test cycle with API

@apuna12 ,

 

Adding to Jagadeesh's inputs, for 401 error you should try deleting and regenerating the API keys once.

 

Regards,

Bibek

apuna12
Occasional Contributor

Re: qsh error when creating test cycle with API

Hello Bibek,

 

Tried that, but the same result

 

Regard,

Tibor

New Here?
Join us and watch the welcome video: