cancel
Showing results for 
Search instead for 
Did you mean: 

ZBot/automation configuration

Harpo
New Contributor

ZBot/automation configuration

I'm trying to setup test automation through Zephyr for Jira, my understanding is that I need to have a ZBot running on my test execution server. I'm trying this out on my dev machine.

I have downloaded the ZBot from Jira from Zephyr and believe I have it configured correctly, but I am having issues getting the ZBot service to start up fully.

 

On the command line, the ZBot is reporting the error

"The agent "my_zbot" is not registered with JIRA server."

I am struggling to find details about how to register my ZBot with Zephyr for Jira.

 

I note in the zbot-application.log it is reporting the following error:

 

ServerStartApplication:198 - Agent started
ScheduledTasks:46 - response status: 302 FOUND
ScheduledTasks:47 - response body: null
AgentServiceImpl:65 - The agent "my_zbot" is not registered with JIRA server.

 

I'm not sure if this points to a more fundamental issue in my ZBot set up and I am being misled by the quite specific "not registered" error on the console.

 

Anyone have any ideas what the issue is?

 

Thanks,

Mark. 

3 REPLIES 3
NeelaReddy
Staff

Re: ZBot/automation configuration

Hi Mark,

 

Zbot is just an application running on the results machine it has to registered with jira server (This can be done through zephyr module).

There are three phases in ZBOT Agent.

1. Running Agent

2. Registering Agent with Jira server

3. Stopping Agent.

 

From your message you are able to start the Agent (It is running) not yet registered with jira server.

Please check the access key correct. it is basic authentication key which you will use for rest calls to be made in jira.

 

if problem still persists you can reach out to support.

 

Thanks

 

Tags (1)
Harpo
New Contributor

Re: ZBot/automation configuration

Thanks for getting back so quickly.

I believe my access key is correct, I'm setting this as the "server.authentication.key" in the zbot.properties file.

I am pulling the key itself from POSTMan as suggested in another topic in here - https://community.smartbear.com/t5/Zephyr-Squad-formerly-Zephyr-for/Unable-to-start-the-Zbot-on-wind...

 

Unfortunately the error response isn't giving me much of a clue why it has not worked, whether it has failed authorisation or something else.

 

From what you have said, I assume it is the ZBot itself which is responsible for registering with Zephyry for Jira? After it has done that I should be able to select my zbot instance while setting up automation in Jira?

NeelaReddy
Staff

Re: ZBot/automation configuration

Hi Again,

 

I assume it is the ZBot itself which is responsible for registering with Zephyry for Jira?

After it has done that I should be able to select my zbot instance while setting up automation in Jira?

 

Yes Zbot agent is responsible to register itself with Zephyr squad.

After registering you can create automation tasks with the registered agents and execute those jobs further.

 

You can raise ticket to support, support team will help you in further debugging the issue.

 

https://support.smartbear.com/zephyr-squad/message/

 

Thanks

New Here?
Join us and watch the welcome video:
Announcements
Top Kudoed Authors