cancel
Showing results for 
Search instead for 
Did you mean: 

Test Execution never finishes While executing test cases Parallel ?

Occasional Contributor

Test Execution never finishes While executing test cases Parallel ?

Hi,

trying to trying to run test cases in parallel and Test Execution never shows as finished

 

Here detailed Problem description:

My Total test run on two csv data input files:

CSV Input Data File-1: GoogleHostList.csv

www.google.com

www.google.com.ua

www.google.co.uk

 

CSV Input Data File-2: SearchStringsInputData.csv

Test Automation

API Automation

web Service Testing

 

Objective:

For each ‘Host Name’ in Input data File-1  , I need to perform search operation for all search strings in input data file -2.

Note: My actiual project is different and it takes(per host and per input value) 2 mins for each set of data.

I have 50 hosts and 10 different input values need to test for each host. Then my total test time will go 50*10*2=1000 minutes;

If I can run 50 test cases in parallel, then I can complete total test in 20 mins.

If I do this search operation sequentially it may take more time and I decided to clone test case into multiple test cases(Equals to number of hosts) and then loop each test case for all given in SearchStrings csv  data file-2.

For this I created  SOAPUI project in the following structure:

 

Project Structure.pngMy Project Structure

Master test case is a template test case and this will be  used replicated/cloned for number of hosts available in  HostList.csv file.

ClonnedTestCases.pngClonnedTestCases

Test Case Replicator groovy script:

Reads CSV Input Data File-1: GoogleHostList.csv

Finds the Number of Hosts

Clones Master Test Case into Number of Hosts times

Updates Each Cloned Test Case Properties

Run Them in Parallel.

 For example, if my CSV Input Data File-1 Contains 3 rows (3 Different Hosts Names) then

Test Case Replicator groovy script Clones the master test case into 3 Copies as below:

www.google.com

www.google.com.ua

www.google.co.uk

 

Then Replicator script updates the Test Case level ‘hostName’ property in all four test cases and then starts them parallel execution mode.

All three cloned test cases are running very fine.

But test SOAPUI projects is not marking as completed even after the test cases are finished.

If we look at execution status at project level, Test Progress bar hangs at TestCaseReplicator Groovy step forever.

ProjectLevel Run Status.pngProject Level Run Status

If we look at the test progress at Test Suite level, TestCaseReplicator Groovy step progress bar reached to 100% and Marked as completed, but at project level still hangs at TestCaseReplicator Groovy step.

TestSuite Level Run Status.pngTest Suite Level Run Status

By design SOAPUI disables the log during the parallel execution.

Even I  tried via command line option using testRunner same issue there as well.

 

Also this problem blocking next clean-up suite forever. How to solve this problem?

Sample project  and sample input data files are attached to reproduce the issue.

 

I am using windows 10 Pro 64 bit Machine.

 

Tried on SOAPUI Open source as well as Ready API Latest Version

 

Ready for joint trouble shoot with support team.

 

Please arrange joint trouble shoot session ASAP.

 

New Here?
Join us and watch the welcome video:
Join the Online Event to Win