Ask a Question

TestExecute - unable to invoke test execute remotely

geethwind
Contributor

TestExecute - unable to invoke test execute remotely

Hi,


 

I got stuck at invoking Test Execute on a remote machine using PSEXEC.


 

I am trying to run .bat file “TE.bat” on a remote machine A from the machine B. The command prompt opens up on A with the .bat content but TestExecute is not opening automatically. After sometime the command prompt gets closed.


 

If I directly run TE.bat on machine A, Test Execute opens without any issues.


Here is the code I am using on Machine B:


C:\>C:\Tools\PSEXEC.exe \\MachineA  -i cmd.exe /c start C:\TE.bat


 

#TE.bat


 

@echo startscripts


“c:\Program Files\Automated QA\TestExecute 8\Bin\TestExecute.exe” “Q:\Root\Projects\TestA\TestA.mds” /r  /exit


 

Any pointers or suggestions to invoke Test Execute from the remote machine would be highly appreciated.



Thanks,

3 REPLIES 3
irina_lukina
Super Contributor

Hi Geeth,


I'm not a PSEXEC guru, but I think that the problem might be in incorrect specifying of the command-line parameters. Have you tried sharing your problem on the following forums?


http://forum.sysinternals.com/ or http://stackoverflow.com


The fact is that it's hard to provide you with high-quality support from our side if the problem isn't in our product. Sorry 🙂

I’m not a member of the SmartBear Support Team, I’m just helping users in this community. Any views or opinions expressed do not necessarily represent those of SmartBear Software.
kethineni_vamsi
Not applicable

Hi Geeth,



I am struggling with the same issue with PSExec . were you able to clear it ?



if yes, can you please help me my posting the solution to my email id "kethineni.vamsi@gmail.com".



Thanks & Regards,

Vamsi Kumar Kethineni
altus_nel
Contributor

Hi,



This may help if this is still a concern for you:



* You will need to identify the session on the remote machine. (You can run it with the command "QUERY SESSION /SERVER:<your_server_name>" You'll get some output for this command. depending on how you're logged on, you should see 1 or more active sessions (in my case it was an active rdp session [2]. if you do not specify the session number it will run as the console session by default [0]



Now, once you have the active session you can use it with the -i option. I.e. psexec -i 2 \\<server_name> notepad.exe 



You can also use the -s switch to run the application with elevated privilages



Regards



cancel
Showing results for 
Search instead for 
Did you mean: