Ask a Question

TestComplete 10 with ESRI ArcMap 10.2.2

oh
Not applicable

TestComplete 10 with ESRI ArcMap 10.2.2

Hello,



first of all I'm new to TestComplete and at the moment I am using the test version.

I'm looking forward to test some Extensions for ESRI ArcMap.



I tryed to open a Dokument with ArcMap. So I started Recording and clicked on File/Open, typed in a Path to a file and stopped recording.

If I want to run the Test I always get this error:


An error occurred while accessing the "Click" method or property of the "menuitemFile" object.

The object or one of its parent objects was not found.



Object Whose Method or Property Was Accessed














Alias:

Aliases.ArcMap.wndAfx.xtpBarTop.panelMainMenu.menuitemFile

Name mapping item:

NameMapping.Sys.ArcMap.wndAfx.xtpBarTop.panelMainMenu.menuitemFile


Object That Was Not Found














Alias:

Aliases.ArcMap.wndAfx

Name mapping item:

NameMapping.Sys.ArcMap.wndAfx


Click the link above to view and configure mapping settings for the missing object.



So I uesed the "Object Spy" to look why the Button "File" in the MenuBar hasn't been found: The Name of a Parent Object seems to change every time I open a new ArcMap Instance. (Object wndAfx now has the Name wndAfx2).

What am I doing wrong?

I tried to shut down every ArcGIS Process, to make shure that only one Instanze of ArcMap is open. But I still get the same error.



Any ideas?



Thanks for your help.

Cheers

Mickey


1 REPLY 1
TanyaYatskovska
SmartBear Alumni (Retired)

Hi Mickey,

 


The specific of Afx windows is that they always have a variable part that will be changed each time. First of all, make sure that the following TestComplete option is enabled: Tools | Options | Engines | General | Object Naming | Auto-correct Afx window class names. TestComplete will use the * wildcard to change the variable part when recording a test. You can read more information in the "Engines - General Options" article.


 


Also, I recommend that you watch the following screencasts that listed the TestComplete features you can use to handle dynamic objects in your app:


---------
Tanya Yatskovskaya
SmartBear Community and Education Manager



cancel
Showing results for 
Search instead for 
Did you mean: