Ask a Question

Secure Sign-in to be disabled (Ctrl+Alt+del)

dave_user
Contributor

Secure Sign-in to be disabled (Ctrl+Alt+del)

Hello,

 

We are using Azure DevOps for our QA regression testing and we have integrated TestComplete with Azure DevOps.

 

We need to have a Interactive session and communication between Azure Devops and the VM where testexecute is installed but because Secure Sign-in is not disabled, TestComplete is not able to create a session on the VM. It only works when we are logged into the VM. Our company policy is having issues allowing this security feature to be disabled.

 

Can somebody please advise what can be a workaround for this and if not then what other security compliance can be put in place alternatively which will not affect the communication?

 

Thank you,

Dave

6 REPLIES 6
mattb
Staff

Hi, 

What type of application are you testing? Could we use a Microsoft hosted agent? Deploy the application or browser to the hosted VM, download TestComplete or TestExecute (recommended) onto that VM during run time and execute the test.


Hello,

 

Hi, 

What type of application are you testing? 

.Net application and mostly these are windows forms.

 

Could we use a Microsoft hosted agent?

unfortunately, we can only use Self Hosted Agents, since we use private cloud and our Azure DevOps is not public.

 

 

Could we enable autologin within the agent?

That's the whole issue. Our company has a security group policy which does not allow to disable the Secure Sign On capability. I have pasted the dialog box. Thats why i was asking if there is any workaround for this? Thanks

 

dave_user_0-1646063601692.jpeg

 

Will this workaround work? More on running on "locked machines" but could be workaround: https://support.smartbear.com/testcomplete/docs/testing-with/running/on-locked-computers.html


Well currently what I am doing is, in the VM where I have installed TestExecute, I usually login to the VM and then run a console script which disconnects the computer and then when we run tests thru Azure DevOps, it seems to be running fine.

 

But this is not the ideal since I have to somehow log into the VM and then disconnect it.

 

Ideally Azure DevOps should create a connection with the VM even if its logged off and then start running the tests but this is currently not happening because of Secure Sign in group policy not allowing me. That's why i was asking if there is a work around to get through this problem.

 

Thank you

 

cancel
Showing results for 
Search instead for 
Did you mean: