Ask a Question

Problems connecting to Microsoft SQL Server with TLS 1.2 using the OLE Driver

andrewa
Contributor

Problems connecting to Microsoft SQL Server with TLS 1.2 using the OLE Driver

We recently upgraded some of our Microsoft sql servers to use TLS 1.2. After that, I noticed that I couldn't make a database connection to them anymore.

 

I have a JScript function that handles connecting to the database. It creates an ADO command and uses a connection string to specify what driver to use and how to connect to the database. The error message that keeps coming back is SSL handshake error. The oddest part is that the Microsoft Sql Server Management Studio connects just fine, it's just Test Complete that has problems.

 

Does anyone know if I can switch which driver TestComplete uses to connect to databases? I think part of the problem is that the OLE driver doesn't support TLS 1.2

2 REPLIES 2
Marsha_R
Community Hero

Re: Problems connecting to Microsoft SQL Server with TLS 1.2 using the OLE Driver

The options here may be of some help:

 

https://support.smartbear.com/testcomplete/docs/testing-with/advanced/working-with-external-data-sou...

Marsha_R
[Community Hero]
____
[Community Heroes] are not employed by SmartBear Software but
are just volunteers who have some experience with the tools by SmartBear Software
and a desire to help others. Posts made by [Community Heroes]
may differ from the official policies of SmartBear Software and should be treated
as the own private opinion of their authors and under no circumstances as an
official answer from SmartBear Software.
The [Community Hero] signature is used with permission by SmartBear Software.
https://community.smartbear.com/t5/custom/page/page-id/hall-of-fame
andrewa
Contributor

Re: Problems connecting to Microsoft SQL Server with TLS 1.2 using the OLE Driver

What I ended up doing to fix/get around the problem was set up an ODBC connection. I went into windows and used the ODBC admin, then modified the connection string I was using. That cleared up the problem really well!

cancel
Showing results for 
Search instead for 
Did you mean: