Ask a Question

Perforce (Source Control) Error After Upgrading to TC 12.41?

heidi_n
Regular Contributor

Perforce (Source Control) Error After Upgrading to TC 12.41?

We updated to TC 12.41 from TC 12.31 and are getting the following error when trying to use Perforce (Source Control) with TC. Is Perforce incompatible with this version, or am I just missing some setup steps?

 

perforce1.png

perforce2.png

Thank you, Heidi / Quality Assurance Specialist
3 REPLIES 3
tristaanogre
Community Hero

Re: Perforce (Source Control) Error After Upgrading to TC 12.41?

As noted, probably on upgrade you switched over to using the 64-bit version of TestComplete... the Perforce provider is probably a 32-bit provider.  If you run the 32-bit version of TestComplete, does it work properly?   That might be a short term work around.

 

In the meantime, you might need to see about getting the 64-bit version of the Perforce provider installed on your environment (if it exists) in order to use it within the 64-bit version of TestComplete.


Robert Martin
[Hall of Fame]
Please consider giving a Kudo if I write good stuff
----

Why automate?  I do automated testing because there's only so much a human being can do and remain healthy.  Sleep is a requirement.  So, while people sleep, automation that I create does what I've described above in order to make sure that nothing gets past the final defense of the testing group.
I love good food, good books, good friends, and good fun.

Mysterious Gremlin Master
Vegas Thrill Rider
Extensions available
heidi_n
Regular Contributor

Re: Perforce (Source Control) Error After Upgrading to TC 12.41?

I'm using Perforce 64 bit. Yes, if I run the 32 bit version of TC it works properly, but I wanted to upgrade to TC 12.41 for Chrome 62 support.

Thank you, Heidi / Quality Assurance Specialist
tristaanogre
Community Hero

Re: Perforce (Source Control) Error After Upgrading to TC 12.41?

Just to clarify... You day you're running the 64-bit version of the Perforce client and it is not working with the 64-bit version of TestComplete? Sounds like a question for support.

However, you do not need to run the 64-bit version of 12.41 to take advantage of the Chrome 62 support... You should be able to run 32-bit TestComplete 12.41 and still have the desired Chrome support. Both versions of TestComplete are installed and available

Robert Martin
[Hall of Fame]
Please consider giving a Kudo if I write good stuff
----

Why automate?  I do automated testing because there's only so much a human being can do and remain healthy.  Sleep is a requirement.  So, while people sleep, automation that I create does what I've described above in order to make sure that nothing gets past the final defense of the testing group.
I love good food, good books, good friends, and good fun.

Mysterious Gremlin Master
Vegas Thrill Rider
Extensions available
cancel
Showing results for 
Search instead for 
Did you mean: