Ask a Question

Instrumenting iOS Applications in Xcode failed

SOLVED
BjoernAdler
New Contributor

Instrumenting iOS Applications in Xcode failed

Hello Community,

would like to instrument a react-native (RN 61.5) app with Xcode (12.1) for TestComplete. Adjusted the new target as described in the documentation.

But Archive failed with:

'React/RCTBridgeDelegate.h' file not found

in AppDelegate.h

Please can you help me.

2 ACCEPTED SOLUTIONS

Accepted Solutions
BjoernAdler
New Contributor

Re: Instrumenting iOS Applications in Xcode failed

Thank you @Marsha_R ,

as you say, google search results pointing only to common issues for that, but nothing related to TestComplete setup.
I redoing all the steps, checking after each if Archive was successful, and at the end then I could build a IPA file.

 

What went wrong on my side? Maybe adding the lib, or set Other Linker Flags was buggy, can't say it exactly.

Now I'm fine.

 

| Created a new Group "App_TestComplete" in Xcode, and added the lib and *_TestComplete.plist into this group.

 

I aprecciate your effort!

View solution in original post

BjoernAdler
New Contributor

Re: Instrumenting iOS Applications in Xcode failed

when using pods, add duplicated target in Podfile

target 'App_Name' do
# ...

  target 'App_Name_TestComplete' do
  end  
end

 will solve the issue

View solution in original post

4 REPLIES 4
Marsha_R
Community Hero

Re: Instrumenting iOS Applications in Xcode failed

I didn't find anything in TestComplete documentation but there's a lot of information other places if you do a Google search.  Here's the one I thought might be most helpful.

 

https://github.com/facebook/react-native/issues/25838

Marsha_R
[Community Hero]
____
[Community Heroes] are not employed by SmartBear Software but
are just volunteers who have some experience with the tools by SmartBear Software
and a desire to help others. Posts made by [Community Heroes]
may differ from the official policies of SmartBear Software and should be treated
as the own private opinion of their authors and under no circumstances as an
official answer from SmartBear Software.
The [Community Hero] signature is used with permission by SmartBear Software.
https://community.smartbear.com/t5/custom/page/page-id/hall-of-fame
BjoernAdler
New Contributor

Re: Instrumenting iOS Applications in Xcode failed

Thank you @Marsha_R ,

as you say, google search results pointing only to common issues for that, but nothing related to TestComplete setup.
I redoing all the steps, checking after each if Archive was successful, and at the end then I could build a IPA file.

 

What went wrong on my side? Maybe adding the lib, or set Other Linker Flags was buggy, can't say it exactly.

Now I'm fine.

 

| Created a new Group "App_TestComplete" in Xcode, and added the lib and *_TestComplete.plist into this group.

 

I aprecciate your effort!

View solution in original post

BjoernAdler
New Contributor

Re: Instrumenting iOS Applications in Xcode failed

Have the same issue after run pod install.

Reason: $(inherited) breaks

Bildschirmfoto 2020-11-17 um 09.50.11.png

 

 

after pod install

image.png

also Check Pods Manifest.lock and Copy Pods Resources are removed from Build Phases

 

Any idea?

BjoernAdler
New Contributor

Re: Instrumenting iOS Applications in Xcode failed

when using pods, add duplicated target in Podfile

target 'App_Name' do
# ...

  target 'App_Name_TestComplete' do
  end  
end

 will solve the issue

View solution in original post

cancel
Showing results for 
Search instead for 
Did you mean: