Ask a Question

I update firefox. Now it's not working on my script.

Nilam
Occasional Contributor

I update firefox. Now it's not working on my script.

I update firefox. Now it's not working on my script. the error is "An error occurred while executing the navigate command". how can i fix this problem and also to know the reason behind it.

3 REPLIES 3
tristaanogre
Community Hero

Re: I update firefox. Now it's not working on my script.

The reason behind it is that the browser has been updated and you need to apply a TestComplete update to use the new browser version.  Go to Help | Check for Updates.  There should be a new update for Firefox available.


Robert Martin
[Hall of Fame]
Please consider giving a Kudo if I write good stuff
----

Why automate?  I do automated testing because there's only so much a human being can do and remain healthy.  Sleep is a requirement.  So, while people sleep, automation that I create does what I've described above in order to make sure that nothing gets past the final defense of the testing group.
I love good food, good books, good friends, and good fun.

Mysterious Gremlin Master
Vegas Thrill Rider
Extensions available
Nilam
Occasional Contributor

Re: I update firefox. Now it's not working on my script.

Currently i am using Test Complete  11.20.1491. my firefox previous version was 44.0.2 and now after update it , it's  57.0.1.
this new version of firefox is not working on Test Complete.
As you said Go to Help | | Check for updates 
here comes, A new version of the product is available 12.41.2879.7
I think it is test complete new version but i do'nt want to update it, my script is ready for execution , i do'nt want to take any risk.
I only need to make my firefox browser workable for the script.Please help
Quote

tristaanogre
Community Hero

Re: I update firefox. Now it's not working on my script.

Keep in mind, I'm not a SmartBear employee so I'm just giving you information based upon what's documented.

 

As far as I can see, TC 11.20 does not support that version of FireFox. Best I can tell is that you need to upgrade to the latest version of TC to get the support for FireFox 57 or roll back your FireFox version to 44.

 

I cannot guarentee it, but you might want to check with SmartBear support directly to see what other possibilities there are for you.  Try https://support.smartbear.com/message/?prod=TestComplete


Robert Martin
[Hall of Fame]
Please consider giving a Kudo if I write good stuff
----

Why automate?  I do automated testing because there's only so much a human being can do and remain healthy.  Sleep is a requirement.  So, while people sleep, automation that I create does what I've described above in order to make sure that nothing gets past the final defense of the testing group.
I love good food, good books, good friends, and good fun.

Mysterious Gremlin Master
Vegas Thrill Rider
Extensions available
cancel
Showing results for 
Search instead for 
Did you mean: