Ask a Question

Ampersand affecting FindChild function

tostig
Member

Ampersand affecting FindChild function

I'm using the .FindChild method to find objects in a table using a series of variables. The function sets a field in a form to a value (ex. x.setTest("ABC")) and submits the form, then tries to find a child object with "ABC" as the innerHTML. This succeeds. The next value is "A&C", submits find, appears on the table, but the .FindChild method isn't able to find it. I'm pretty sure it's the ampersand preventing it from being found.

 

Unfortunately, the ampersand isn't optional. Any help would be appreciated.

 

Thanks,

Tostig

2 REPLIES 2
Marsha_R
Community Hero

Re: Ampersand affecting FindChild function

Sometimes with special characters, putting two of them helps, so try &&

Marsha_R
[Community Hero]
____
[Community Heroes] are not employed by SmartBear Software but
are just volunteers who have some experience with the tools by SmartBear Software
and a desire to help others. Posts made by [Community Heroes]
may differ from the official policies of SmartBear Software and should be treated
as the own private opinion of their authors and under no circumstances as an
official answer from SmartBear Software.
The [Community Hero] signature is used with permission by SmartBear Software.
https://community.smartbear.com/t5/custom/page/page-id/hall-of-fame
sonya_m
Community Manager

Re: Ampersand affecting FindChild function

Thanks for the advice here, Marsha!

 

@tostig does this work for you?


Sonya Mihaljova
Community and Education Specialist

Did my reply answer your question? Give Kudos or Accept it as a Solution to help others. ⬇️⬇️⬇️
cancel
Showing results for 
Search instead for 
Did you mean: