cancel
Showing results for 
Search instead for 
Did you mean: 

Your application uses PatchServices library that is not compatible with your TestComplete version

siv_arunprakash
Contributor

Your application uses PatchServices library that is not compatible with your TestComplete version

We have upgraded our TestComplete version from 12 to 14.0

When I tried to launch an instrumented application , we receive a message "You application uses the PatchServices library that is not compatible with your TestComplete version".

 

Then I searched for solutions in smartbear community and tried the following from,

https://support.smartbear.com/testcomplete/docs/app-testing/mobile/android/preparing/instrumenting-a...

 

  • Deleted the previous instrumented application.
  • Created a new project suite and instrumented the original APK with TestComplete 14.0 in TestedApps.
  • Installed the TestComplete android agent as well.
  • After instrumentation is completed from TestComplete, I ran the package installation and the application is launched , but I receive the same warning message " You application uses the PatchServices library that is not compatible with your TestComplete version ".
  • But everything works fine if I try the same procedure in TestComplete 12.0.

 

Please help if anyone faced this issue.

Also note that , I do not have the Android project. So I could not add the patchservices.jar in lib folder and package it. I download the APK from google play store and extracted the APK using file explorer software and then instrument that APK.

1 REPLY 1
Marsha_R
Community Hero

Re: Your application uses PatchServices library that is not compatible with your TestComplete versio

I suggest that you contact Support directly with your question.  Here's the link:

https://support.smartbear.com/message/?prod=TestComplete

 

New Here?
Join us and watch the welcome video:
Announcements