cancel
Showing results for 
Search instead for 
Did you mean: 

2 Errors "not a valid Android application." or "install packages" when I try add not instrument app

SOLVED
Highlighted
Occasional Contributor

2 Errors "not a valid Android application." or "install packages" when I try add not instrument app

Hi all!

 

I want understand - what is wrong?

 

I have two errors: 

1)

2020-10-29_6-22-34.png

2)

2020-10-29_6-49-40.png

when I try add not instrument android application in project

 

This article says

https://support.smartbear.com/testcomplete/docs/app-testing/mobile/android/preparing/computers.html

 

that I must have

  • Android 10.x (on the SDK Platforms tab)

  • Android SDK Platform-tools

  • Android SDK Build-tools ver. 26.0.2 or later

and other...

 

On my computer was installed:

1. Android 

2020-10-29_6-16-29.png

2. Java (JDK):

2020-10-29_6-21-19.png

3. TestComplete Extensions

2020-10-29_6-25-52.png

4. TestComplete Settings

2020-10-29_6-35-56.png

My Env:

Windows 7 (x86), Sp1

TestComplete 14.7

 

Thanks

1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted
Occasional Contributor

Re: 2 Errors "not a valid Android application." or "install packages" when I try

Hey ya!

 

I have found solution:

1. All files of SDK must be placed on one folder (In TC 14.61, 14.6 etc I just set folder where adb.exe placed, not all SDK folder, WHY your programmers change it?????)

2. In field "Path to Android SDK" we need set path without "backslash" on end (Hey, This important information!, because "C:\Folder" - worked, "C:\folder\"- not worked)

3. The same for set java runtime - best, set jre and without "backslash", f.e. C:\Program Files\Java\jre1.8.0_271 (In TC 14.61, 14.6 etc I set jdk folder and it work perfectly, guys what is wrong with you???)

 

P.S. 

If some one need just Android SDK folder, without problem of download via cmd sdkmanager, I can archive it and give some link to it (f.e. this help for test on x86)

View solution in original post

4 REPLIES 4
Highlighted
Occasional Contributor

Re: 2 Errors "not a valid Android application." or "install packages" when I try

Hey ya!

 

I have found solution:

1. All files of SDK must be placed on one folder (In TC 14.61, 14.6 etc I just set folder where adb.exe placed, not all SDK folder, WHY your programmers change it?????)

2. In field "Path to Android SDK" we need set path without "backslash" on end (Hey, This important information!, because "C:\Folder" - worked, "C:\folder\"- not worked)

3. The same for set java runtime - best, set jre and without "backslash", f.e. C:\Program Files\Java\jre1.8.0_271 (In TC 14.61, 14.6 etc I set jdk folder and it work perfectly, guys what is wrong with you???)

 

P.S. 

If some one need just Android SDK folder, without problem of download via cmd sdkmanager, I can archive it and give some link to it (f.e. this help for test on x86)

View solution in original post

Highlighted
Community Manager

Re: 2 Errors "not a valid Android application." or "install packages" when I try

Hi @NikitaPyatakov ! Thank you for posting the question.

 

@AlexKaras @Marsha_R @Wamboo any ideas on what might be the cause? 

I feel like opening a ticket with support might be required in this case to investigate more. 


Sonya Mihaljova
Community and Education Specialist

Did my reply answer your question? Give Kudos or Accept it as a Solution to help others. ⬇️⬇️⬇️
Highlighted
Community Hero

Re: 2 Errors "not a valid Android application." or "install packages" when I try

I agree with tossing this to Support.  Install issues are difficult to figure out without seeing what's happening in the backend.  

Highlighted
Community Manager

Re: 2 Errors "not a valid Android application." or "install packages" when I try

Thank you for sharing @NikitaPyatakov !


Sonya Mihaljova
Community and Education Specialist

Did my reply answer your question? Give Kudos or Accept it as a Solution to help others. ⬇️⬇️⬇️
New Here?
Join us and watch the welcome video:
Announcements
Top Kudoed Authors