Ask a Question

testexecute with /silentmode parameter does not start test

mikakoistinen
Contributor

testexecute with /silentmode parameter does not start test

Hi, 

I noticed that I can't run our tests with testexecute using /silentmode parameter. (desktop test, if it matters)

this works

  path_to_te\TestExecute.exe c:\testit\winskj\winskj.pjs /p:winskj /run /ns  /e /ForceConversion

this just starts TE and stops it

  path_to_te\TestExecute.exe c:\testit\winskj\winskj.pjs /p:winskj /run /ns  /e /silentmode /ForceConversion

It has been working earlier in 12.5, but hasn't been working after upgrade to 12.6.  

Any idea what's causing problem?

 

Jeemly - Dream Big
https://jeemly.com/
3 REPLIES 3
tristaanogre
Community Hero

Re: testexecute with /silentmode parameter does not start test

We just rolled out TE 12.6 and our run last night did fine with /SilentMode set.  The problem MIGHT be with the ForceConversion switch.  That switch only triggers when you use the SilentMode switch.  So, something is being converted in your project or there is some sort of error in the conversion.  Have you checked the silent log as indicated in https://support.smartbear.com/testcomplete/docs/working-with/automating/command-line-and-exit-codes/...?


Robert Martin
[Hall of Fame]
Please consider giving a Kudo if I write good stuff
----

Why automate?  I do automated testing because there's only so much a human being can do and remain healthy.  Sleep is a requirement.  So, while people sleep, automation that I create does what I've described above in order to make sure that nothing gets past the final defense of the testing group.
I love good food, good books, good friends, and good fun.

Mysterious Gremlin Master
Vegas Thrill Rider
Extensions available
mikakoistinen
Contributor

Re: testexecute with /silentmode parameter does not start test

Actually there shouldn't be anything to convert. I use 12.6 TC also. /forceconversion is just in case if there is something to convert in future. 

 

I run TE as normal user, from command line. 

silent.log is not modifed after upgrade and neither new is created when i rename it as .old

Access rights should be okey, I checked them. 

Jeemly - Dream Big
https://jeemly.com/
tristaanogre
Community Hero

Re: testexecute with /silentmode parameter does not start test

Just out of curiousity, what happens if you run it with /SilentMode but without /ForceConversion?


Robert Martin
[Hall of Fame]
Please consider giving a Kudo if I write good stuff
----

Why automate?  I do automated testing because there's only so much a human being can do and remain healthy.  Sleep is a requirement.  So, while people sleep, automation that I create does what I've described above in order to make sure that nothing gets past the final defense of the testing group.
I love good food, good books, good friends, and good fun.

Mysterious Gremlin Master
Vegas Thrill Rider
Extensions available
cancel
Showing results for 
Search instead for 
Did you mean: