cancel
Showing results for 
Search instead for 
Did you mean: 

The operation cannot be performed, because the desktop is invisible.

SOLVED
Highlighted
Contributor

The operation cannot be performed, because the desktop is invisible.

Hi,

 

In the past, my tests were running fine while remote desktop is minimized.

 

After getting a new computer (this is the one that connects to a remote desktop system), I added a DWORD value named RemoteDesktop_SuppressWhenMinimized and set it to 2 (hexadecimal or decimal) to HKEY_LOCAL_MACHINE\Software\Microsoft\Terminal Server Client.

 

I also updated TestComplete to version 14.50.976.7 on the remote system.

 

Now, I got the error message saying that :"The operation cannot be performed, because the desktop is invisible." when minimizing the remote desktop.

Does anyone seeing the same issue with the latest TestComplete version? Can anyone shed some light? Thanks.

1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted
Community Hero

Re: The operation cannot be performed, because the desktop is invisible.

That's a good question for Support.  Here's their link:

https://support.smartbear.com/message/?prod=TestComplete

View solution in original post

3 REPLIES 3
Highlighted
Community Hero

Re: The operation cannot be performed, because the desktop is invisible.

That's a good question for Support.  Here's their link:

https://support.smartbear.com/message/?prod=TestComplete

View solution in original post

Community Leader

Re: The operation cannot be performed, because the desktop is invisible.

Highlighted
Contributor

Re: The operation cannot be performed, because the desktop is invisible.

@Marsha_R, Sean ONeil at SmartBear helped me to solve this issue. There was an extra whitespace at the end in the name of my registry key.

New Here?
Join us and watch the welcome video:
Announcements
Top Kudoed Authors