cancel
Showing results for 
Search instead for 
Did you mean: 

TestExecute install fails with Error code -1, seeing previous installation even though not exists

SOLVED
Highlighted
Occasional Contributor

TestExecute install fails with Error code -1, seeing previous installation even though not exists

This is on a Windows 10 Pro physical machine. This is the error:

Selecting Upgrade or Uninstall getting the error.

Blocked on this one, sent opened a ticket.

 

Thanks for any help on resolving.

 

Nathan

 

 

2 ACCEPTED SOLUTIONS

Accepted Solutions
Highlighted
Community Manager

Re: TestExecute install fails with Error code -1, seeing previous installation even though not exist

I see that the issue was solved by removing certain keys before installing the new product version at the advice of the Support team. This is a general idea, but if anyone's facing a similar behavior, they should contact support to get directions on what keys to remove.


Sonya Mihaljova
Community and Education Specialist

Did my reply answer your question? Give Kudos or Accept it as a Solution to help others. ⬇️⬇️⬇️

View solution in original post

Highlighted
Occasional Contributor

Re: TestExecute install fails with Error code -1, seeing previous installation even though not exist

this worked:

Our developers want you to remove the following keys before install new version of TE:

Computer\HKEY_LOCAL_MACHINE\SOFTWARE\WOW6432Node\Microsoft\Windows\CurrentVersion\Uninstall{E1430B2E-6973-1440-8233-724BAC44AAF2}
Computer\HKEY_LOCAL_MACHINE\SOFTWARE\WOW6432Node\Microsoft\Windows\CurrentVersion\Uninstall\InstallShield_{E1430B2E-6973-1440-8233-724BAC44AAF2}
Computer\HKEY_LOCAL_MACHINE\SOFTWARE\WOW6432Node\Microsoft\Windows\CurrentVersion\Uninstall{E1430B2E-6973-1450-8233-724BAC44AAF2}
Computer\HKEY_LOCAL_MACHINE\SOFTWARE\WOW6432Node\Microsoft\Windows\CurrentVersion\Uninstall\InstallShield_{E1430B2E-6973-1450-8233-724BAC44AAF2}
Computer\HKEY_LOCAL_MACHINE\SOFTWARE\WOW6432Node\Microsoft\Windows\CurrentVersion\Uninstall{E1430B2E-6973-1460-8233-724BAC44AAF2}
Computer\HKEY_LOCAL_MACHINE\SOFTWARE\WOW6432Node\Microsoft\Windows\CurrentVersion\Uninstall\InstallShield_{E1430B2E-6973-1460-8233-724BAC44AAF2}
Computer\HKEY_LOCAL_MACHINE\SOFTWARE\WOW6432Node\SmartBear\TestExecute\14.0


Afterwards, try installing the latest release of TestExecute and see if the issue still occurs. 


View solution in original post

4 REPLIES 4
Highlighted
Community Manager

Re: TestExecute install fails with Error code -1, seeing previous installation even though not exist

@nathanginoza for such questions contacting support is a good way to proceed since this requires deeper investigation most probably. I found your ticket (00452204) please keep working with the support engineers there. We would really appreciate it if you share the results of your investigation with the Community too when you get them, thank you. 


Sonya Mihaljova
Community and Education Specialist

Did my reply answer your question? Give Kudos or Accept it as a Solution to help others. ⬇️⬇️⬇️
Highlighted
Occasional Contributor

Re: TestExecute install fails with Error code -1, seeing previous installation even though not exist

Thank you Sonya, I still have not solved my problem.

Nathan

 

Highlighted
Community Manager

Re: TestExecute install fails with Error code -1, seeing previous installation even though not exist

I see that the issue was solved by removing certain keys before installing the new product version at the advice of the Support team. This is a general idea, but if anyone's facing a similar behavior, they should contact support to get directions on what keys to remove.


Sonya Mihaljova
Community and Education Specialist

Did my reply answer your question? Give Kudos or Accept it as a Solution to help others. ⬇️⬇️⬇️

View solution in original post

Highlighted
Occasional Contributor

Re: TestExecute install fails with Error code -1, seeing previous installation even though not exist

this worked:

Our developers want you to remove the following keys before install new version of TE:

Computer\HKEY_LOCAL_MACHINE\SOFTWARE\WOW6432Node\Microsoft\Windows\CurrentVersion\Uninstall{E1430B2E-6973-1440-8233-724BAC44AAF2}
Computer\HKEY_LOCAL_MACHINE\SOFTWARE\WOW6432Node\Microsoft\Windows\CurrentVersion\Uninstall\InstallShield_{E1430B2E-6973-1440-8233-724BAC44AAF2}
Computer\HKEY_LOCAL_MACHINE\SOFTWARE\WOW6432Node\Microsoft\Windows\CurrentVersion\Uninstall{E1430B2E-6973-1450-8233-724BAC44AAF2}
Computer\HKEY_LOCAL_MACHINE\SOFTWARE\WOW6432Node\Microsoft\Windows\CurrentVersion\Uninstall\InstallShield_{E1430B2E-6973-1450-8233-724BAC44AAF2}
Computer\HKEY_LOCAL_MACHINE\SOFTWARE\WOW6432Node\Microsoft\Windows\CurrentVersion\Uninstall{E1430B2E-6973-1460-8233-724BAC44AAF2}
Computer\HKEY_LOCAL_MACHINE\SOFTWARE\WOW6432Node\Microsoft\Windows\CurrentVersion\Uninstall\InstallShield_{E1430B2E-6973-1460-8233-724BAC44AAF2}
Computer\HKEY_LOCAL_MACHINE\SOFTWARE\WOW6432Node\SmartBear\TestExecute\14.0


Afterwards, try installing the latest release of TestExecute and see if the issue still occurs. 


View solution in original post

New Here?
Join us and watch the welcome video:
Announcements
Top Kudoed Authors