cancel
Showing results for 
Search instead for 
Did you mean: 

TestComplete and LoadComplete integration

SOLVED
mgroen2
Super Contributor

TestComplete and LoadComplete integration

Hi,
I followed the steps described here:
https://support.smartbear.com/viewarticle/78749/

However, when followed steps, I get an error: Communication Error.

See attached video for illustration.

Do other have similar issues? Anyone know how to fix this?


Thanks,
Mathijs

1 ACCEPTED SOLUTION

Accepted Solutions
mgroen2
Super Contributor

Re: TestComplete and LoadComplete integration

I received a following from support desk, and it solved the issue.

 

 


Please apply the following patch and let me know your results:

Patch Installation Instructions for TestComplete 12.20.
1. Download the patch archive (TestComplete_12_20_CC_9231.zip) using the following link:
https://s3.amazonaws.com/webtocasefiles.smartbear/Patches/TestComplete/12/12.20/CC-9231/TestComplete...
2. After you have downloaded the archive, unzip the patch file to the appropriate location (back up the existing file before doing this, just in case):
\Bin\aqMarshaller.dll => %programfiles(x86)%\SmartBear\TestComplete 12\Bin\aqMarshaller.dll

 

View solution in original post

4 REPLIES 4
tristaanogre
Community Hero

Re: TestComplete and LoadComplete integration

Double check your firewall settings with regards to LoadComplete.  My guess is that the port that LoadComplete uses for it's transponder for recording traffic is getting blocked.

Have you attempted just a quick recording of a load test in LoadComplete to make sure that you can do so outside of the integration?  That would be my first step in debugging.  


Robert Martin
[Hall of Fame]
Please consider giving a Kudo if I write good stuff
----

Why automate?  I do automated testing because there's only so much a human being can do and remain healthy.  Sleep is a requirement.  So, while people sleep, automation that I create does what I've described above in order to make sure that nothing gets past the final defense of the testing group.
I love good food, good books, good friends, and good fun.

Mysterious Gremlin Master
Vegas Thrill Rider
Extensions available
mgroen2
Super Contributor

Re: TestComplete and LoadComplete integration


@tristaanogre wrote:

Double check your firewall settings with regards to LoadComplete.  My guess is that the port that LoadComplete uses for it's transponder for recording traffic is getting blocked.

Have you attempted just a quick recording of a load test in LoadComplete to make sure that you can do so outside of the integration?  That would be my first step in debugging.  


Hi @tristaanogre,

 

I double checked firewall settings, they were enabled.

I recorded a simple load test in LoadComplete, it worked.

 

Still getting the same error message.

 

tristaanogre
Community Hero

Re: TestComplete and LoadComplete integration

In LoadComplete (it's been a few years since I've used the tool extensively), what is the port being used by the transponder? It's possible, I think, that TestComplete may be having a conflict as TestComplete uses a TCP/IP port for Network Suite communications.  If there's a port conflict, that could be the problem.

In my TC installation, TC is using ports 6090, 6091, and 6092.  LoadComplete, by default, uses 8889.

There are other services and such involved in the integration process. If certain services aren't running, things could not work well. I'm also wondering about version compatibility.  The documentation in TC says you must have LoadComplete version 3.20 or later and you must have the Web Module in TestComplete.  Also, there's some notation that, in order for TestComplete and LoadComplete to work together, they must both be executed with the same privilege level.  Another note indicates that if your NameMapping in your project doesn't actually include a "browser" object, then the integration won't work either.  There doesn't appear to be any specific documentation on "Connection Error" but these are the next things to check.

 

Something else to try is to run LoadComplete manually before hitting the button to create a Load Test.  It could be possible that there's a problem with starting the LoadComplete application due to some environment factor.  Again, in this situation, make sure that TestComplete and LoadComplete are both operating with the same privilege level. That could be something else to check... see if running them both "As Administrator" clears up the problem.

If you still can't get anywhere, then it's probably something beyond my current level of experience.  See if someone from SmartBear can help with a support ticket.


Robert Martin
[Hall of Fame]
Please consider giving a Kudo if I write good stuff
----

Why automate?  I do automated testing because there's only so much a human being can do and remain healthy.  Sleep is a requirement.  So, while people sleep, automation that I create does what I've described above in order to make sure that nothing gets past the final defense of the testing group.
I love good food, good books, good friends, and good fun.

Mysterious Gremlin Master
Vegas Thrill Rider
Extensions available
mgroen2
Super Contributor

Re: TestComplete and LoadComplete integration

I received a following from support desk, and it solved the issue.

 

 


Please apply the following patch and let me know your results:

Patch Installation Instructions for TestComplete 12.20.
1. Download the patch archive (TestComplete_12_20_CC_9231.zip) using the following link:
https://s3.amazonaws.com/webtocasefiles.smartbear/Patches/TestComplete/12/12.20/CC-9231/TestComplete...
2. After you have downloaded the archive, unzip the patch file to the appropriate location (back up the existing file before doing this, just in case):
\Bin\aqMarshaller.dll => %programfiles(x86)%\SmartBear\TestComplete 12\Bin\aqMarshaller.dll

 

View solution in original post

New Here?
Join us and watch the welcome video:
Announcements