cancel
Showing results for 
Search instead for 
Did you mean: 

TestComplete 14.10.1042.7 and Windows 10 performance

Contributor

TestComplete 14.10.1042.7 and Windows 10 performance

Hello,

The performance of certain operations is "extremely" slow when using TestComplete or if TestComplete is opened.  Example:

1. Open TC

2. Open tested application

3. Perform an operation via TestComplete (example: clicking an item in a menu)

4. Result: takes 60 seconds for operation to complete

5. Perform same operation manually

6. Results: takes 35 seconds

5. Close TC

6. Perform same operation

7. Results: takes 10 seconds

 

How can this performance issue be resolved?

This didn't occur on my Windows 7 laptop- only started happening on Windows 10 laptop.

I've unchecked the Windows Store Applications option.

I've checked all the Desktop install extensions.

 

Thanks in advanced!!!

Kim

10 REPLIES 10
Community Hero

Re: TestComplete 14.10.1042.7 and Windows 10 performance

Since you've moved TC to another computer, this may be of some help:

 

https://support.smartbear.com/testcomplete/docs/working-with/best-practices/computer-specific-settin...

Contributor

Re: TestComplete 14.10.1042.7 and Windows 10 performance

Marsha, thanks for the reply.  I double-checked and the settings are correct.

-Kim

Highlighted
Community Hero

Re: TestComplete 14.10.1042.7 and Windows 10 performance

Check the Windows Updates section here.  There are some Win 10 performance issues listed:

https://support.smartbear.com/testcomplete/docs/general-info/configuring/windows-specifics.html

Contributor

Re: TestComplete 14.10.1042.7 and Windows 10 performance

I gave that a try and it didn't improve the performance.

 

-Kim

Community Hero

Re: TestComplete 14.10.1042.7 and Windows 10 performance

I suggest that you contact Support directly with your question.  Here's the link:

https://support.smartbear.com/message/?prod=TestComplete

Community Hero

Re: TestComplete 14.10.1042.7 and Windows 10 performance

One of the big things to change is under Tools | Options | Engines | General -> Turn off the option for Windows Store Applications and restart TestComplete.  That might help.


Robert Martin
[Community Expert Group]
Please consider giving a Kudo if I write good stuff
----

Why automate?  I do automated testing because there's only so much a human being can do and remain healthy.  Sleep is a requirement.  So, while people sleep, automation that I create does what I've described above in order to make sure that nothing gets past the final defense of the testing group.
I love good food, good books, good friends, and good fun.

Mysterious Gremlin Master
Extensions available
Contributor

Re: TestComplete 14.10.1042.7 and Windows 10 performance

Hi Robert,

Thanks for the suggestion.  I already unchecked that option.

I'm also running TestComplete as admin.

Thanks,

Kim

Community Manager

Re: TestComplete 14.10.1042.7 and Windows 10 performance

Hi @kimmatsumoto,

It's worth checking the PC's system requirements:

https://support.smartbear.com/testcomplete/docs/general-info/system-requirements.html

 

Also, please follow the steps listed in the following article to enhance TestComplete performance:

https://support.smartbear.com/testcomplete/docs/working-with/best-practices/performance-tips.html

 

If none of the suggestions help, please contact the Support Team by using the link Marsha provided - they will need to look at the issue deeper.

---------
Tanya Gorbunova
SmartBear Community Manager

Join the September Hub-bub to show off, learn and win
Contributor

Re: TestComplete 14.10.1042.7 and Windows 10 performance

Thank you for all the respones.  I've submitted the issue to Support.

-Kim

New Here?
Join us and watch the welcome video:
Watch the New Interview
7Mistakes
Join the September Hub-bub to show off, learn and win