cancel
Showing results for 
Search instead for 
Did you mean: 

Test Complete cannot launch Edge (Chromium-based) browser

SOLVED
XBug
Contributor

Test Complete cannot launch Edge (Chromium-based) browser

Hi,

 

I  cannot launch Microsoft Edge (chromium-based, Version 90.0.818.56 (Official build) (64-bit)) using Test Complete. I kept on getting the error below:

An internal error occurred while running the Microsoft Edge browser.
Details: Unspecified error
 
Other browsers were fine.
 
I saw a similar post - "Unspecified error" when trying to launch Microsoft Edge browser - but the issue was supposed to be solved by updating to the recent version of TC, which I did (currently using v 14.81.217.7 of TC) but still I am getting the error.
 
I have gone through Preparing Edge for Web Testing but got the same error still.
 
Hoping anyone can help me out.
Tags (1)
1 ACCEPTED SOLUTION

Accepted Solutions
XBug
Contributor

Re: Test Complete cannot launch Edge (Chromium-based) browser

@Marsha_R yes, I also wrote an email to the Support. I was thinking that the forum might offer something.

 

Below is the fix that Support gave:

  1. Run Code Snippet operations to perform the Browsers.Item(btEdge).RunOptions = "--do-not-de-elevate" assignment.
  2. Run Script Routine with the following function
    1. br = Browsers.Item(btEdge);

      br.RunOptions = "--do-not-de-elevate";

      br.Run(); 

View solution in original post

4 REPLIES 4
Marsha_R
Community Hero

Re: Test Complete cannot launch Edge (Chromium-based) browser

the other suggestion I made in that previous post was to contact Support directly - that's still a good idea

 

https://support.smartbear.com/testcomplete/message

XBug
Contributor

Re: Test Complete cannot launch Edge (Chromium-based) browser

@Marsha_R yes, I also wrote an email to the Support. I was thinking that the forum might offer something.

 

Below is the fix that Support gave:

  1. Run Code Snippet operations to perform the Browsers.Item(btEdge).RunOptions = "--do-not-de-elevate" assignment.
  2. Run Script Routine with the following function
    1. br = Browsers.Item(btEdge);

      br.RunOptions = "--do-not-de-elevate";

      br.Run(); 

View solution in original post

Marsha_R
Community Hero

Re: Test Complete cannot launch Edge (Chromium-based) browser

What happened when you tried what Support suggested?

XBug
Contributor

Re: Test Complete cannot launch Edge (Chromium-based) browser

I tried and am now using the code snippet, it works fine. 🙂

New Here?
Join us and watch the welcome video:
Announcements