cancel
Showing results for 
Search instead for 
Did you mean: 

Script broken after migration to windows 10 1909

SOLVED
Highlighted
New Contributor

Script broken after migration to windows 10 1909

The script has no issue while executing under windows 10 1803.  

After uprading to 1909, the script failed to execute and had the following pop-up

 

Wrong number of arguments or invalid property assignment: 'Parent.WaitChild(...).Exists'
Error location:
Unit: "SS_Automation\SS_XXXXX\Script\ObjectUtils"
Line: 151 Column: 3. is

 

if Parent.WaitChild(Child,0).exists then

1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted
New Contributor

Re: Script broken after migration to windows 10 1909

The issue was fixed after upgrading TC to version 12.6.

View solution in original post

4 REPLIES 4
Highlighted
Community Hero

Re: Script broken after migration to windows 10 1909

The code is very non specific.  My guess is that whatever "parent" is, it's not longer a valid object and so the other parts of the code are not going to work.

Depending on what you are doing, some properties may have changed values with the Windows upgrade... but it's hard to tell without mmore info.


Robert Martin
[Community Expert Group]
Please consider giving a Kudo if I write good stuff
----

Why automate?  I do automated testing because there's only so much a human being can do and remain healthy.  Sleep is a requirement.  So, while people sleep, automation that I create does what I've described above in order to make sure that nothing gets past the final defense of the testing group.
I love good food, good books, good friends, and good fun.

Mysterious Gremlin Master
Vegas Thrill Rider
Extensions available
Highlighted
Community Manager

Re: Script broken after migration to windows 10 1909

Thank you for the suggestion tristaanogre. 

 

HI @philipchan , was the issue solved for you?

If not, please share a bit more info for the Community to try helping you further. Thank you.


Sonya Mihaljova
Community and Education Specialist

 Join the virtual SmartBear Connect user conference on April 27-28! Get your free virtual ticket today!
Highlighted
New Contributor

Re: Script broken after migration to windows 10 1909

The issue was fixed after upgrading TC to version 12.6.

View solution in original post

Highlighted
Community Manager

Re: Script broken after migration to windows 10 1909

Thank you for sharing that @philipchan ! Awesome news.


Sonya Mihaljova
Community and Education Specialist

 Join the virtual SmartBear Connect user conference on April 27-28! Get your free virtual ticket today!