cancel
Showing results for 
Search instead for 
Did you mean: 

Routines not found - Since 14.80

SOLVED
mcbane
Occasional Contributor

Routines not found - Since 14.80

Since 14.80, I've been getting [Routines not found] in the drop-down when opening a script. There are no scripting errors in the files--it's all of them. Restarting TestComplete does not change anything (per another topic I found when searching this issue).

 

Occasionally, when I have several scripts open, the sections of one script will show up in the drop-down, but not the one I have in focus. So choosing one of the sections takes me to the wrong line in the script I have in focus. I've had to resort to using the Find feature to navigate my scripts. Is anyone else experiencing this?

 

Thanks in advance!

1 ACCEPTED SOLUTION

Accepted Solutions
mcbane
Occasional Contributor

Re: Routines not found - Since 14.80

Downloaded 14.81.

 

FIXED!

 

Thank you so much for fixing this.

 

Thank you, @tsand, for submitting the support ticket to get it fixed.

 

All is now right with the world. 😀

View solution in original post

8 REPLIES 8
Marsha_R
Community Hero

Re: Routines not found - Since 14.80

mcbane
Occasional Contributor

Re: Routines not found - Since 14.80

Thank you!

However, everything runs fine. I just can't use the drop-down to navigate to the different functions.

 

Tommy

Marsha_R
Community Hero

Re: Routines not found - Since 14.80

I'd ask Support that question directly.  Here's the link:

https://support.smartbear.com/testcomplete/message

tsand
New Contributor

Re: Routines not found - Since 14.80

Yes, facing same issue. Using jscript as language!

 

Regards

mcbane
Occasional Contributor

Re: Routines not found - Since 14.80

I have found a inconvenient workaround. If I create a new function in the script (by manually typing it), the drop-down rebuilds correctly and works until an unspecified time--when it reverts back to being empty.

 

Tommy

tsand
New Contributor

Re: Routines not found - Since 14.80

Right, for me it is also enough if you just type a new character or a space, then the drop-down is showing the correct functions.

But I don't like to type always a new character to get the functions. 😉

Especially, my source control SVN is recognizing the change, when I forgot to undo the change before a save.

@mcbanehave you created a ticket for the support?

 

Thilo

mcbane
Occasional Contributor

Re: Routines not found - Since 14.80

I never looked that close. Yes, just typing a character rebuilds the drop-down.

I haven't sent in a support ticket. They aren't going to be able to reproduce it without my entire copy of TestComplete--and possibly my computer 😂. The drop-down has given me grief for many months--causing occasional crashes--but the latest update introduced it blanking out or even showing the functions from the last script I was on instead of the current.

I'm sure it will get worked out eventually. 😉

 

Tommy

mcbane
Occasional Contributor

Re: Routines not found - Since 14.80

Downloaded 14.81.

 

FIXED!

 

Thank you so much for fixing this.

 

Thank you, @tsand, for submitting the support ticket to get it fixed.

 

All is now right with the world. 😀

View solution in original post

New Here?
Join us and watch the welcome video:
Announcements
Top Kudoed Authors