cancel
Showing results for 
Search instead for 
Did you mean: 

Problems with name mapping and Test Complete hanging

Contributor

Problems with name mapping and Test Complete hanging

I am testing an HTML 5 application that runs inside of Chrome. I'm running into a problem involving name mapping.



- using the Object Spy I highlight a text box in the HTML 5 application

- it takes roughly 10 seconds (usually it's instant) for the property fields in the Object Spy dialog to populate

- once they do populate, Test Complete become completely unresponsive. In fact the mouse pointer disappears if I hover it over any part of Test Complete

- however if I close HTML 5 application, Test Complete instantly becomes responsive again as if nothing ever went wrong



I've been wrestling with it for too long now and it's very frustrationg. Heck it drove me to actually post on here because I'm currently at a loss. I believe the problem has something to do with name mapping. I say this because of something I discovered while troubleshooting...



- I closed down Test Complete and removed the name mapping file from my project

- reopened Test Complete where I got the missing name mapping error as expected, said ok to it and moved on

- tried the detailed steps listed above and to my surprise, no issues whatever

- spied the text box, properties filled in the Object Spy dialog instantly and Test Complete never hung



So to me that means there is something going on with my name mapping but I'm not sure what it may be. Anyone have some ideas?!
-----If you post a problem on a forum, whenever you figure out a solution for it, please post your solution so others may benefit!----->
14 REPLIES 14
Community Manager

RE: Problems with name mapping and Test Complete hanging


Hi Jeremy,


 


Most probably, the behavior you describe depends on the Store Code Completion information option. Make sure that its value is set to Store brief Code Completion data or Do not store Code Completion data.


Also, make sure that you are using the latest TestComplete version - v.9.31.


 

---------
Tanya Gorbunova
SmartBear Community Manager

Did my reply answer your question? Give Kudos or Accept it as a Solution to help others.↓↓↓↓↓
Contributor

RE: Problems with name mapping and Test Complete hanging

I have tried both Store brief Code Completion data and Do not store Code Completion data and neither had any effect. I'm still experiencing the same symptoms.
-----If you post a problem on a forum, whenever you figure out a solution for it, please post your solution so others may benefit!----->
Contributor

RE: Problems with name mapping and Test Complete hanging

Anyone?
-----If you post a problem on a forum, whenever you figure out a solution for it, please post your solution so others may benefit!----->
Community Manager

RE: Problems with name mapping and Test Complete hanging


Hi Jeremy,


 


What TestComplete version are you using? I've heard about a similar issue in TestComplete 9.0.


 

---------
Tanya Gorbunova
SmartBear Community Manager

Did my reply answer your question? Give Kudos or Accept it as a Solution to help others.↓↓↓↓↓
Contributor

RE: Problems with name mapping and Test Complete hanging

I'm using 9.31.



I have since discovered that if I wait long enough (5 minutes or so), Test Complete will become responsive again (though very choppy) and I can then map the object. Once I have the object mapped, all appears to work ok...so far. I'm still not sure why certain objects are causing it to freak out. I know we use Dojo Toolkit pretty extensively which leads to objects being buried often 10+ levels deep.
-----If you post a problem on a forum, whenever you figure out a solution for it, please post your solution so others may benefit!----->
Community Manager

RE: Problems with name mapping and Test Complete hanging


Hi Jeremy,


 


It looks like you will need to contact our Support team as some investigation is required.


 


BTW, we've recently released TestComplete 10. Can you try using this product version to check whether the problem exists?


 

---------
Tanya Gorbunova
SmartBear Community Manager

Did my reply answer your question? Give Kudos or Accept it as a Solution to help others.↓↓↓↓↓
Contributor

RE: Problems with name mapping and Test Complete hanging

I looked into that but the website says 9.31 is the latest, couldn't find anything about Test Complete 10.
-----If you post a problem on a forum, whenever you figure out a solution for it, please post your solution so others may benefit!----->
Community Manager

RE: Problems with name mapping and Test Complete hanging


Hi Jeremy,


 


You can request a free trial version here:



 

---------
Tanya Gorbunova
SmartBear Community Manager

Did my reply answer your question? Give Kudos or Accept it as a Solution to help others.↓↓↓↓↓
Occasional Contributor

RE: Problems with name mapping and Test Complete hanging

Hello,



I am having problem with name mapping where my parent has became Empty Object. Because of that I could not find any child.  What action should I take to resolve this/.



Thanks



 
New Here?
Join us and watch the welcome video:
API Testing Mistake #2
APITestingMistake#2