cancel
Showing results for 
Search instead for 
Did you mean: 

Keywordtest with parameter having default value

pmm
Occasional Contributor

Keywordtest with parameter having default value

I have a Keywordtest that has an optinal parameter with a default value (a filename in this case). But when i run my test from the inside the keywordtest editior (run from the selected operation) the parameter seems to be empty. The same behaviour when I run it from the project menue and leave the parameter unassigned. Only if I assign a value and run from the project menue it works as expected. What I'm doing wrong? Or is that a known restriction?

PMM
PMM
2 REPLIES 2

RE: Keywordtest with parameter having default value

Hi Peter,


Thank you for reporting the problem. We will try to reproduce it and let you know our results as soon as we have some.



Best regards,
Alexey

Did my reply answer your question? Give Kudos or Accept it as a Solution to help others. ⬇️⬇️⬇️

RE: Keywordtest with parameter having default value

Hi Peter,

 

We have reproduced the problem with ignored default parameters, and we will try to fix it in one of future TestComplete versions.

 

>>>

The same behaviour when I run it from the project menue and leave the parameter unassigned

<<<

When you do this, the parameter still takes on a value. There is no way to omit the parameter if you use this approach. 

 

Best regards,
Alexey

Did my reply answer your question? Give Kudos or Accept it as a Solution to help others. ⬇️⬇️⬇️
New Here?
Join us and watch the welcome video:
Announcements