cancel
Showing results for 
Search instead for 
Did you mean: 

First of many extensions - nothing added in keyword editor

SOLVED
Highlighted
Super Contributor

First of many extensions - nothing added in keyword editor

I am working on my first script extension as I attempt to neaten up some of the repetitive things that need to be done. I get my lovely item in the keyword test operations pallette. I drag it into a keyword test. The form I created is popped. I fill in fields and click OK. I know the OK code segment is running properly because I had some aqDlg.ShowMessages in there. 

 

No columns or any data at all is being added to the test.

 

Can anyone tell me what might be causing this? Extension source attached.

1 ACCEPTED SOLUTION

Accepted Solutions
Community Hero

Re: First of many extensions - nothing added in keyword editor

I'm looking through it.  Couple of things:

1) You have data fields defined but no parameters for the operation.  I think this might play a part because there is some indication that you need to actually assign values to the parameters.

2) The OK button, I think, needs to have a ModalResult of mrNone and have an OnClick event which sets the FORM modal result to mrOk

 


Robert Martin
[Community Expert Group]
Please consider giving a Kudo if I write good stuff
----

Why automate?  I do automated testing because there's only so much a human being can do and remain healthy.  Sleep is a requirement.  So, while people sleep, automation that I create does what I've described above in order to make sure that nothing gets past the final defense of the testing group.
I love good food, good books, good friends, and good fun.

Mysterious Gremlin Master
Vegas Thrill Rider
Extensions available

View solution in original post

5 REPLIES 5
Community Hero

Re: First of many extensions - nothing added in keyword editor

I'm looking through it.  Couple of things:

1) You have data fields defined but no parameters for the operation.  I think this might play a part because there is some indication that you need to actually assign values to the parameters.

2) The OK button, I think, needs to have a ModalResult of mrNone and have an OnClick event which sets the FORM modal result to mrOk

 


Robert Martin
[Community Expert Group]
Please consider giving a Kudo if I write good stuff
----

Why automate?  I do automated testing because there's only so much a human being can do and remain healthy.  Sleep is a requirement.  So, while people sleep, automation that I create does what I've described above in order to make sure that nothing gets past the final defense of the testing group.
I love good food, good books, good friends, and good fun.

Mysterious Gremlin Master
Vegas Thrill Rider
Extensions available

View solution in original post

Highlighted
Super Contributor

Re: First of many extensions - nothing added in keyword editor

Thanks. Starting with #2, I can confirm that the modal setting is correct by virtue of the fact that that code executes properly. (This is how they do it in the tutorial as well.) 

 

wrt #1

1) You have data fields defined but no parameters for the operation.  I think this might play a part because there is some indication that you need to actually assign values to the parameters.

 

Parameters for which operation? Which parameters?

Highlighted
Community Manager

Re: First of many extensions - nothing added in keyword editor

Hi @vthomeschoolmom,

 

As far as I understand, the same question is discussed here:

https://community.smartbear.com/t5/TestComplete-General-Discussions/Keyword-operation-script-extensi...

 

Let's keep the conversation in that thread - there are much more suggestions there.

---------
Tanya Gorbunova
SmartBear Community Manager

 Join SmartBear Connect next April in Boston to meet with software development, API and testing experts from around the world! Get your ticket today!
Highlighted
Super Contributor

Re: First of many extensions - nothing added in keyword editor

Most likely case at this time is that Robert is right. I stripped the extension of everything other than the description.xml stuff for the keyword editor. No form, and thus no response to form.

 

More info to follow. 

 

(See https://support.smartbear.com/testcomplete/docs/working-with/extending/script/creating/keyword-test-...)

Highlighted
Super Contributor

Re: First of many extensions - nothing added in keyword editor

ANd, of course, it is Robert for the win.