cancel
Showing results for 
Search instead for 
Did you mean: 

Distributed Test not initializing

jsayre
Occasional Contributor

Distributed Test not initializing

When I try to start up a job that I have created with a test in it on a remote machine, I get the follow message:



Cannot load the remote project. Not all the projects that are currently open on the slave computer contain the NetworkSuite project item



I have my projects setup correctly to the best of my knowledge. Any other possible fixes or reasons for this error?
7 REPLIES 7
TanyaYatskovska
Community Manager

RE: Distributed Test not initializing


Hi Jeremy,


 


Was the screenshot made on the master computer? Make sure that the project on your slave computer contains the NetworkSuite node.


 

---------
Tanya Yatskovskaya
SmartBear Community and Education Manager

Did my reply answer your question? Give Kudos or Accept it as a Solution to help others. ⬇️⬇️⬇️
jsayre
Occasional Contributor

RE: Distributed Test not initializing

That SS is from the master computer. I found that the slave computer was looking for the network suite in a strange place. It was looking for it inside of a folder called "TestComplete Components" located at C:\TestComplete Components\~



Is there any reason that this would default to looking in a different folder for the network suite?
augustine_uzokw_1
Contributor

RE: Distributed Test not initializing

@smartBear experts: 

i have similar issue with the error, were there a solution provided to this?
jsayre
Occasional Contributor

RE: Distributed Test not initializing

I ended up needing to manually transfer the networksuite to the location it was looking for it. I haven't found a place to manually configure it to look in another location.
augustine_uzokw_1
Contributor

RE: Distributed Test not initializing

Thanks for the quick reply.

i have no clue of the exact networksuite item TC is looking for else i would've manually copied to the slave. 

can you please feed me this information?



thanks
augustine_uzokw_1
Contributor

RE: Distributed Test not initializing

Now i understand what TC wants however it's not clear enough the way it's descripbed on the support page what should be done and cost time to figure it out.



a networksuite item needs to be added to the project (e.g. in Advace folder) with just a host machine added to it with the same details (address, domain, username & password) as in the host that holds the tasks
TanyaYatskovska
Community Manager

RE: Distributed Test not initializing


Hi Augustine,


 


See the following tutorial - it contains detailed steps to set up master and slave projects: "Distributed Testing Tutorial" 

---------
Tanya Yatskovskaya
SmartBear Community and Education Manager

Did my reply answer your question? Give Kudos or Accept it as a Solution to help others. ⬇️⬇️⬇️
New Here?
Join us and watch the welcome video:
Announcements
Top Kudoed Authors