cancel
Showing results for 
Search instead for 
Did you mean: 

regarding recording web application using test complete

SOLVED
Highlighted
New Contributor

regarding recording web application using test complete

while recording with test complete web application where in i need to enter username and password,its recording absolutely properly but on playback i am getting the error on the username textbox that "textbox username not identified".

1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted
Community Hero

The object does not exist error has nothing to do with whether or not it is mapped.  You're mapping is there... but the object itself either 

 

a) doesn't exist YET in memory because the page still needs to render it or

b) there are dynamic factors using in your mapping criteria so that, every time you run the automation the object has a different property value.

 

a can be resolved by applying appropriate "wait" logic for the object before attempting to use it.

b can be resolved by editing the mapping of the object and either adding wild-cards for the dynamic portions of the property or by choosing different properties as the identification criteria that don't have dynamic values.

 

AS @TanyaGorbunova mentioned, there are great tutorials in the help file and in videos available from SmartBear on how to do either of these.


Robert Martin
[Hall of Fame]
Please consider giving a Kudo if I write good stuff
----

Why automate?  I do automated testing because there's only so much a human being can do and remain healthy.  Sleep is a requirement.  So, while people sleep, automation that I create does what I've described above in order to make sure that nothing gets past the final defense of the testing group.
I love good food, good books, good friends, and good fun.

Mysterious Gremlin Master
Vegas Thrill Rider
Extensions available

View solution in original post

9 REPLIES 9
Highlighted
Community Hero

Hi,

 

Assuming that you did recording using default settings, can you:

a) Provide a screenshot of the problem reported to the test log (with Additional Info pane been visible);

b) Provide a screenshot of how username text box was defined in NameMapping; and

c) What is the HTML markup for the username text box in your tested application?

 

Regards,
  /Alex [Community Hero]
____
[Community Heroes] are not employed by SmartBear Software but
are just volunteers who have some experience with the tools by SmartBear Software
and a desire to help others. Posts made by [Community Heroes]
may differ from the official policies of SmartBear Software and should be treated
as the own private opinion of their authors and under no circumstances as an
official answer from SmartBear Software.
The [Community Hero] signature is used with permission by SmartBear Software.
https://community.smartbear.com/t5/custom/page/page-id/hall-of-fame
================================
Highlighted
New Contributor

Hi Alex,

 

Please find attached the word document along with the screenshots for the above said problems.

Highlighted
Community Manager

Hi, 

Thanks for posting the file. For some reason, my Word doesn't show the images inside the file. Could you please attach them to the post?

 

 

---------
Tanya Gorbunova
SmartBear Community Manager

Learn SmartBear products in a fun and easy way and prove your knowledge!
>>Participate in the TechCorner Challenge today
Highlighted
New Contributor

testlog.PNGhtmlmarkup.PNGmappedobjects.PNG

Highlighted
New Contributor

Hi I have attached the images in the post itself. Could u please see and try and give an resolution.

Highlighted
Community Manager

Hi @sakshi29,

We have a great learning course where we explain how to handle the Object Not Found error. To avoid getting this error you need to debug your test. You can easily do this by following the steps from the course.

 

 

---------
Tanya Gorbunova
SmartBear Community Manager

Learn SmartBear products in a fun and easy way and prove your knowledge!
>>Participate in the TechCorner Challenge today
Highlighted
Community Hero

The object does not exist error has nothing to do with whether or not it is mapped.  You're mapping is there... but the object itself either 

 

a) doesn't exist YET in memory because the page still needs to render it or

b) there are dynamic factors using in your mapping criteria so that, every time you run the automation the object has a different property value.

 

a can be resolved by applying appropriate "wait" logic for the object before attempting to use it.

b can be resolved by editing the mapping of the object and either adding wild-cards for the dynamic portions of the property or by choosing different properties as the identification criteria that don't have dynamic values.

 

AS @TanyaGorbunova mentioned, there are great tutorials in the help file and in videos available from SmartBear on how to do either of these.


Robert Martin
[Hall of Fame]
Please consider giving a Kudo if I write good stuff
----

Why automate?  I do automated testing because there's only so much a human being can do and remain healthy.  Sleep is a requirement.  So, while people sleep, automation that I create does what I've described above in order to make sure that nothing gets past the final defense of the testing group.
I love good food, good books, good friends, and good fun.

Mysterious Gremlin Master
Vegas Thrill Rider
Extensions available

View solution in original post

Highlighted
Community Hero

Hi,

 

Thank you for the screenshots.

Can you also post here the code that does not work?

 

Regards,
  /Alex [Community Hero]
____
[Community Heroes] are not employed by SmartBear Software but
are just volunteers who have some experience with the tools by SmartBear Software
and a desire to help others. Posts made by [Community Heroes]
may differ from the official policies of SmartBear Software and should be treated
as the own private opinion of their authors and under no circumstances as an
official answer from SmartBear Software.
The [Community Hero] signature is used with permission by SmartBear Software.
https://community.smartbear.com/t5/custom/page/page-id/hall-of-fame
================================
Community Manager

Thank you everyone for being helpful 😊 

 

Hi @sakshi29, did you manage to resolve the issue? If not, please provide more details, like what AlexKaras is asking – having the code that doesn’t work would be nice. 


Sonya Mihaljova
Community and Education Specialist

Learn SmartBear products in a fun and easy way and prove your knowledge!
>>Participate in the TechCorner Challenge today
New Here?
Join us and watch the welcome video:
Announcements
Join TechCorner Challenge!
Want a fun and easy way to learn TestComplete? Try solving weekly TechCorner challenges and get into the Leaderboard!


Challenge Status

Get properties of a web page element

See replies!

Compare images using the Region Checkpoint

See replies!

Compare HTML table with Excel file and correct data in Excel file

Participate!

How to execute remote test and obtain results via Test Runner REST API

Participate!
Top Kudoed Authors