cancel
Showing results for 
Search instead for 
Did you mean: 

regarding recording web application using test complete

SOLVED
Highlighted
New Contributor

regarding recording web application using test complete

while recording with test complete web application where in i need to enter username and password,its recording absolutely properly but on playback i am getting the error on the username textbox that "textbox username not identified".

1 ACCEPTED SOLUTION

Accepted Solutions
Community Hero

Re: regarding recording web application using test complete

The object does not exist error has nothing to do with whether or not it is mapped.  You're mapping is there... but the object itself either 

 

a) doesn't exist YET in memory because the page still needs to render it or

b) there are dynamic factors using in your mapping criteria so that, every time you run the automation the object has a different property value.

 

a can be resolved by applying appropriate "wait" logic for the object before attempting to use it.

b can be resolved by editing the mapping of the object and either adding wild-cards for the dynamic portions of the property or by choosing different properties as the identification criteria that don't have dynamic values.

 

AS @TanyaGorbunova mentioned, there are great tutorials in the help file and in videos available from SmartBear on how to do either of these.


Robert Martin
[Community Expert Group]
Please consider giving a Kudo if I write good stuff
----

Why automate?  I do automated testing because there's only so much a human being can do and remain healthy.  Sleep is a requirement.  So, while people sleep, automation that I create does what I've described above in order to make sure that nothing gets past the final defense of the testing group.
I love good food, good books, good friends, and good fun.

Mysterious Gremlin Master
Vegas Thrill Rider
Extensions available

View solution in original post

9 REPLIES 9
Community Hero

Re: regarding recording web application using test complete

Hi,

 

Assuming that you did recording using default settings, can you:

a) Provide a screenshot of the problem reported to the test log (with Additional Info pane been visible);

b) Provide a screenshot of how username text box was defined in NameMapping; and

c) What is the HTML markup for the username text box in your tested application?

 

Regards,
Alex
[Community Expert Group]
____
[Community Expert Group] members are not employed by SmartBear Software but
are just volunteers who have some experience with the tools by SmartBear Software
and a desire to help others. Postings made by [Community Expert Group] members
may differ from the official policies of SmartBear Software and should be treated
as the own private opinion of their authors and under no circumstances as an
official answer from SmartBear Software.
[Community Expert Group] signature is used with permission by SmartBear Software.
http://smartbear.com/forums/f83/t86934/community-experts/
================================
New Contributor

Re: regarding recording web application using test complete

Hi Alex,

 

Please find attached the word document along with the screenshots for the above said problems.

Community Manager

Re: regarding recording web application using test complete

Hi, 

Thanks for posting the file. For some reason, my Word doesn't show the images inside the file. Could you please attach them to the post?

 

 

---------
Tanya Gorbunova
SmartBear Community Manager

 Join SmartBear Connect next April in Boston to meet with software development, API and testing experts from around the world! Get your ticket today!
New Contributor

Re: regarding recording web application using test complete

testlog.PNGhtmlmarkup.PNGmappedobjects.PNG

New Contributor

Re: regarding recording web application using test complete

Hi I have attached the images in the post itself. Could u please see and try and give an resolution.

Community Manager

Re: regarding recording web application using test complete

Hi @sakshi29,

We have a great learning course where we explain how to handle the Object Not Found error. To avoid getting this error you need to debug your test. You can easily do this by following the steps from the course.

 

 

---------
Tanya Gorbunova
SmartBear Community Manager

 Join SmartBear Connect next April in Boston to meet with software development, API and testing experts from around the world! Get your ticket today!
Community Hero

Re: regarding recording web application using test complete

The object does not exist error has nothing to do with whether or not it is mapped.  You're mapping is there... but the object itself either 

 

a) doesn't exist YET in memory because the page still needs to render it or

b) there are dynamic factors using in your mapping criteria so that, every time you run the automation the object has a different property value.

 

a can be resolved by applying appropriate "wait" logic for the object before attempting to use it.

b can be resolved by editing the mapping of the object and either adding wild-cards for the dynamic portions of the property or by choosing different properties as the identification criteria that don't have dynamic values.

 

AS @TanyaGorbunova mentioned, there are great tutorials in the help file and in videos available from SmartBear on how to do either of these.


Robert Martin
[Community Expert Group]
Please consider giving a Kudo if I write good stuff
----

Why automate?  I do automated testing because there's only so much a human being can do and remain healthy.  Sleep is a requirement.  So, while people sleep, automation that I create does what I've described above in order to make sure that nothing gets past the final defense of the testing group.
I love good food, good books, good friends, and good fun.

Mysterious Gremlin Master
Vegas Thrill Rider
Extensions available

View solution in original post

Community Hero

Re: regarding recording web application using test complete

Hi,

 

Thank you for the screenshots.

Can you also post here the code that does not work?

 

Regards,
Alex
[Community Expert Group]
____
[Community Expert Group] members are not employed by SmartBear Software but
are just volunteers who have some experience with the tools by SmartBear Software
and a desire to help others. Postings made by [Community Expert Group] members
may differ from the official policies of SmartBear Software and should be treated
as the own private opinion of their authors and under no circumstances as an
official answer from SmartBear Software.
[Community Expert Group] signature is used with permission by SmartBear Software.
http://smartbear.com/forums/f83/t86934/community-experts/
================================
Community Manager

Re: regarding recording web application using test complete

Thank you everyone for being helpful 😊 

 

Hi @sakshi29, did you manage to resolve the issue? If not, please provide more details, like what AlexKaras is asking – having the code that doesn’t work would be nice. 



Sonya Mihaljova
Community and Education Specialist

 Join SmartBear Connect next April in Boston to meet with software development, API and testing experts from around the world! Get your ticket today!