cancel
Showing results for 
Search instead for 
Did you mean: 

Unspecified Error received when running all tests in suite

SOLVED
Highlighted
Occasional Visitor

Unspecified Error received when running all tests in suite

Hi Support,

Recently me and my colleagues installed Test Complete 14. We seem to get an 'Unspecified error' when running all the test in test suite. The first tests run ok and at some point durring the execution of one of the  tests Test Complete throws and 'Unspecified error' message and none of the following tests are executed. The tests run perfectly fine when runned independently. On the previous versions of Test Complete we didn't get this error (v10 & v12).

Any ideas why can cause this problem?

 

Thank you

1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted
Community Hero

Re: Unspecified Error received when running all tests in suite

Usually, when I see that error, that indicates something more on the lines of a problem with something that is a code syntax or similar problem.  Maybe even if you're calling some sort of external object call within your code and something is not properly initializnig taht call.  If you double-click on the error, it SHOULD take you to the general area in your test that raised the error.  That should give you some clue as to what might be going on.  Do so and share with us so we can continue to help.


Robert Martin
[Hall of Fame]
Please consider giving a Kudo if I write good stuff
----

Why automate?  I do automated testing because there's only so much a human being can do and remain healthy.  Sleep is a requirement.  So, while people sleep, automation that I create does what I've described above in order to make sure that nothing gets past the final defense of the testing group.
I love good food, good books, good friends, and good fun.

Mysterious Gremlin Master
Vegas Thrill Rider
Extensions available

View solution in original post

2 REPLIES 2
Highlighted
Community Hero

Re: Unspecified Error received when running all tests in suite

Usually, when I see that error, that indicates something more on the lines of a problem with something that is a code syntax or similar problem.  Maybe even if you're calling some sort of external object call within your code and something is not properly initializnig taht call.  If you double-click on the error, it SHOULD take you to the general area in your test that raised the error.  That should give you some clue as to what might be going on.  Do so and share with us so we can continue to help.


Robert Martin
[Hall of Fame]
Please consider giving a Kudo if I write good stuff
----

Why automate?  I do automated testing because there's only so much a human being can do and remain healthy.  Sleep is a requirement.  So, while people sleep, automation that I create does what I've described above in order to make sure that nothing gets past the final defense of the testing group.
I love good food, good books, good friends, and good fun.

Mysterious Gremlin Master
Vegas Thrill Rider
Extensions available

View solution in original post

Highlighted
Community Manager

Re: Unspecified Error received when running all tests in suite

Hi @gabrielaB,

Was the issue resolved? What solution did you decide to use?

---------
Tanya Gorbunova
SmartBear Community Manager

Learn SmartBear products in a fun and easy way and prove your knowledge!
>>Participate in the TechCorner Challenge today
New Here?
Join us and watch the welcome video:
Announcements
Join TechCorner Challenge!
Want a fun and easy way to learn TestComplete? Try solving weekly TechCorner challenges and get into the Leaderboard!

Challenge Status

Changing options from outside of TestComplete

Participate!

How to execute remote test and obtain results via Test Runner REST API

Participate!

Comparing content of HTML table with Excel file data

Participate!

Compare HTML table with Excel file and correct data in the file

Participate!
Top Kudoed Authors