cancel
Showing results for 
Search instead for 
Did you mean: 

Unspecified Error received when running all tests in suite

SOLVED
Highlighted
Occasional Visitor

Unspecified Error received when running all tests in suite

Hi Support,

Recently me and my colleagues installed Test Complete 14. We seem to get an 'Unspecified error' when running all the test in test suite. The first tests run ok and at some point durring the execution of one of the  tests Test Complete throws and 'Unspecified error' message and none of the following tests are executed. The tests run perfectly fine when runned independently. On the previous versions of Test Complete we didn't get this error (v10 & v12).

Any ideas why can cause this problem?

 

Thank you

1 ACCEPTED SOLUTION

Accepted Solutions
Community Hero

Re: Unspecified Error received when running all tests in suite

Usually, when I see that error, that indicates something more on the lines of a problem with something that is a code syntax or similar problem.  Maybe even if you're calling some sort of external object call within your code and something is not properly initializnig taht call.  If you double-click on the error, it SHOULD take you to the general area in your test that raised the error.  That should give you some clue as to what might be going on.  Do so and share with us so we can continue to help.


Robert Martin
[Community Expert Group]
Please consider giving a Kudo if I write good stuff
----

Why automate?  I do automated testing because there's only so much a human being can do and remain healthy.  Sleep is a requirement.  So, while people sleep, automation that I create does what I've described above in order to make sure that nothing gets past the final defense of the testing group.
I love good food, good books, good friends, and good fun.

Mysterious Gremlin Master
Vegas Thrill Rider
Extensions available

View solution in original post

2 REPLIES 2
Community Hero

Re: Unspecified Error received when running all tests in suite

Usually, when I see that error, that indicates something more on the lines of a problem with something that is a code syntax or similar problem.  Maybe even if you're calling some sort of external object call within your code and something is not properly initializnig taht call.  If you double-click on the error, it SHOULD take you to the general area in your test that raised the error.  That should give you some clue as to what might be going on.  Do so and share with us so we can continue to help.


Robert Martin
[Community Expert Group]
Please consider giving a Kudo if I write good stuff
----

Why automate?  I do automated testing because there's only so much a human being can do and remain healthy.  Sleep is a requirement.  So, while people sleep, automation that I create does what I've described above in order to make sure that nothing gets past the final defense of the testing group.
I love good food, good books, good friends, and good fun.

Mysterious Gremlin Master
Vegas Thrill Rider
Extensions available

View solution in original post

Community Manager

Re: Unspecified Error received when running all tests in suite

Hi @gabrielaB,

Was the issue resolved? What solution did you decide to use?

---------
Tanya Gorbunova
SmartBear Community Manager

Did my reply answer your question? Give Kudos or Accept it as a Solution to help others.↓↓↓↓↓