cancel
Showing results for 
Search instead for 
Did you mean: 

Unable to navigate for any browser on latest TC 14 with all browsers updated

SOLVED
Contributor

Unable to navigate for any browser on latest TC 14 with all browsers updated

Based on reading other posts with this issue it would appear something is not up to date, however i have everything up to date and i am unable to navigate to my targeted URL. it just opens the browsers and then does nothing until it times out. This was working before but now I am unable to run any of my tests. 
 
This log references FF, but it's happening in chrome and edge also. 
Logs
 
Mozilla Firefox was launched
Browser: Mozilla Firefox ver.66.0.5 (x64)
Executable: C:\Program Files (x86)\Mozilla Firefox\firefox.exe
Command-line args:  
URL:  
PID: 2616
You are trying to call the "Preferences" method or property of the "Sys.Browser("firefox")" object that does not exist.
You are trying to call the "setBoolPref" method or property of the "Sys.Browser("firefox").Preferences" object that does not exist.
Process ID: 2616
Process Command Line: "C:\Program Files (x86)\Mozilla Firefox\firefox.exe"
Info: Cannot find any existing or open blank page.
NameMapping.Sys.Process("firefox")
 
What else should I be looking at? 
1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted
Contributor

Re: Unable to navigate for any browser on latest TC 14 with all browsers updated

"Process Filter" settings and make sure that "Process filter mode" is set to "Use all processes". 

View solution in original post

3 REPLIES 3
Community Hero

Re: Unable to navigate for any browser on latest TC 14 with all browsers updated

I suggest that you contact Support directly with your issue.  Here's the link:

https://support.smartbear.com/message/?prod=TestComplete

Community Hero

Re: Unable to navigate for any browser on latest TC 14 with all browsers updated

Hi,

 

> "Sys.Browser("firefox")" object that does not exist.

a) Have you installed a patch for FF 66 ? (https://support.smartbear.com/downloads/testcomplete/firefox-patches/)

b) Can we see a relevant piece of your code?

 

Regards,
Alex
[Community Expert Group]
____
[Community Expert Group] members are not employed by SmartBear Software but
are just volunteers who have some experience with the tools by SmartBear Software
and a desire to help others. Postings made by [Community Expert Group] members
may differ from the official policies of SmartBear Software and should be treated
as the own private opinion of their authors and under no circumstances as an
official answer from SmartBear Software.
[Community Expert Group] signature is used with permission by SmartBear Software.
http://smartbear.com/forums/f83/t86934/community-experts/
================================
Highlighted
Contributor

Re: Unable to navigate for any browser on latest TC 14 with all browsers updated

"Process Filter" settings and make sure that "Process filter mode" is set to "Use all processes". 

View solution in original post

New Here?
Join us and watch the welcome video:
Watch the new Interview