cancel
Showing results for 
Search instead for 
Did you mean: 

Troubles clicking Mainmenu-Items Windows 7

Occasional Contributor

Troubles clicking Mainmenu-Items Windows 7

Hi all,



recently I updated to TC 7.52. I found a very strange behaviour running existing tests recorded with TC 7.1.

In this case TC is testing a windows-mdi-application. Most tests start by clicking a menu-item from the main menu

of the tested app. Most of these clicks do what they are supposed to.

Some do not work at all because the menu item is never clicked and therefore the following teststep cannot be

executed. If I slow down test-execution to be able to see how the menu-item is selected, I discovered that the

desired sub-menu is not selected due to the fact that the mouse leaves the dropdown-list and clicks somewhere

else.



What really bugs me is the fact that all of the tests have worked, and after restarting the test-suite I get hundreds

of errors where there are none? I do not want to change all of the tests to selecting the desired submenu by using

the down keys to navigate within the dropdown because this will only work until someone adds another item to the

list.



Any ideas, is this a bug? What can I do?



Greets



c:
3 REPLIES 3
Staff

RE: Troubles clicking Mainmenu-Items Windows 7

Hi Carsten,



Can you zip the entire project suite directory along with logs and send it to us?



Also, make sure that the latest log of the failed test execution corresponds to the latest version of your test (there have been no modifications in the test since the last test log was generated).

------
Yuri
TestComplete Customer Care Engineer

Did my reply answer your question? Give Kudos or Accept it as a Solution to help others.
Occasional Contributor

RE: Troubles clicking Mainmenu-Items Windows 7

Thanks for Your answer here, and Yes I have recieved and replied to Your mails,



Didn´t You get the test-suite and logs?



Please let me know, and I´ll upload it here.



Regards Carsten
Community Manager

RE: Troubles clicking Mainmenu-Items Windows 7


Hi Carsten,





We still haven't got your project suite.





Probably, your firewall blocks it. Please check your network settings and try to send us your project suite one more time via e-mail (the M0069696 support case).





If the same situation occurs again, we'll provide you with access to our FTP site where you could upload your suite.
-----

Alexander
Customer Care Manager
New Here?
Join us and watch the welcome video:
6 / 7 API Testing Mistakes Video
Top Kudoed Authors